Razer SurroundSound driver not working/installing

Discussion in 'Razer Support' started by frontTealDeerbook415, Oct 13, 2019.

  1. So recently I've decided that I would reinstall some stuff on my computer, Synapse 2.0 happened to be one of those things. But I've realized I did a dum, because now when I use my Razer Man O War headset (wired edition), I can't use surround sound at all. It will calibrate, but I won't hear it, I also won't see it in the Razer mixer portion of Synapse.

    Here's a few pictures of me having the ability to apparently calibrate the SurroundSound feature.
    https://i.imgur.com/uJTuLiu.png
    https://i.imgur.com/FaPWQl7.png

    Now, I've tried completely uninstalling Synapse 2.0, removing any registries I could find, files and etc. Then I've reinstalled Synape through the WebDownloader on the official site, restarted, installed and restarted again and finally when Synapse was full updated I plugged in my headset, which prompted a driver update wizard, which again I went through. However, in the end, everything seems to install fine BUT the SurroundSound drivers.

    I've also tried looking in to grabbing a RazerSurroundSound Pro download (which is for headsets that don't have the 7.1 built in/available) but that asks me to give an activation key which I don't have.

    Please help, someone, anyone. I don't have a warranty, and at the moment I lack the funds to purchase a new headset.
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Thanks for posting your concern here. That's really inconvenient. Please send me a PM together with the email associated with your Razer Synapse account and your headset's serial number. Let's continue from there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >