Razer Synaps 3 Audio Mixer Tab THX not functioning

Discussion in 'Razer Support' started by lazardaddy, Dec 3, 2020.

Thread Status:
Not open for further replies.
  1. lazardaddy

    lazardaddy New Member

    Hi, I just bought a Razer Blackshark V2 and installed Razer Synapse 3. I updated Synapse 3 to the latest version.

    Everything seems to work apart from the Audio/Mixer tab which seems to be completely broken. See screenshot below.

    upload_2020-12-3_14-14-23.png

    1) No applications are shown under Games & Programs. If I add one, it does not get added.
    2) Spatial audio modes has nothing in the drop-down and you cannot add anything
    3) The Calibration radar only shows one speaker, but when you click to listen it does play a sound from each of the 7 zones. Spacially this sounds about right too, but as there are no speakers or modes one cannot calibrate the speakers. Which is one of the main reasons I bought the Razer headset.

    I have set Spatial THX Audio as default.

    I have tried the following:
    - Rebooted
    - Removed USB and plugged it in again
    - rebooted
    - Uninstalled all Razer products, including with Advanced Uninstaller Pro, and done a clean install (many times)
    - Did an install on a clean desktop PC that never had Razer products installed with the same result.

    Not very impressed with the Razer software. Thinking of returning the headset and going with something else if the software is this bad.

    Any help appreciated.

    Thanks
     
    spikewj likes this.
  2. spikewj

    spikewj New Member

    I have the same symptom with my Razer Blackshark V2.

    At first I can see the Spatial THX AUDIO and can set it as default, but Audio/Mixer tab seems to be broken ( try to add a game, but it's not added, and the same screen as this)

    Thus, I tried to uninstall and clean install, now Spatial THX AUDIO device is gone (wow!) and Audio/Mixer tab is broken as before.

    I tried the uninstall / clean install, but Spatial THX AUDIO device didn't show up.

    I'm very disappointed with the Razor software, I spent several hours to make it work but failed.

    Help needed!!
     
  3. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! Thanks for posting a thorough report of the Razer Synapse 3.0's concern here. Please submit a case to our Support Team or send me a PM.

    Hey spikewj! I've replied to your PM. I'll wait for your follow-up.
     
  4. lazardaddy

    lazardaddy New Member

    Hi Razer.SpeedCr0ss, I did raise a support ticket (*Omitted) with no response yet. I also have a second ticket from chat support yesterday (*Omitted) which the agent said will need to go to 2nd line.

    Thank you for your help!
     
  5. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! I've removed your case number for your security. By the way, I've seen that the team replied to your email and provided troubleshooting. Please let them know the results of the performed steps. I notified the team as well. Feel free to send me a PM should you need additional assistance. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >