Razer Synapse 2.0 on macOS High Sierra issue

Discussion in 'Razer Synapse' started by RADIUMU92-SSBPLASMA, Feb 6, 2018.

  1. RADIUMU92-SSBPLASMA

    RADIUMU92-SSBPLASMA New Member

    I had recently updated my razer synapse program for my mac, and about a day after, the application would open but it wouldn't load my configurations for my razer devices. It would only show the green buffering circle and I left like this for about a hour, and still nothing load4ed. If anyone can give me some help with this issue, it would be much appreciated. Thank you.
     
    ricstar, osnabb, easyjay39402 and 4 others like this.
  2. franctastic

    franctastic Member

    With the latest update of macOS to 10.13.4 beta (17E150g), Synapse has stopped working!
    Do not update!
    I uninstalled Synapse, reinstalled Synapse, and it’s NOT RUNNED!

    CRASH!

    [​IMG]

    a disaster!

    salut!
     
    Last edited: Feb 11, 2018
    Bobyfile, Nilremagl, NZ_Fox and 2 others like this.

  3. I had the same problem on the last major beta test.
    What we got to remember is that Mac OS 10.13.4 is a beta, and most software developers will not release their updated software until a full OS (stable) is released.
    Other wise they will be pouring resources in to an OS that might go through several changes of it's beta cycle, and having to rewrite things all the time.
     
    Nilremagl and NZ_Fox like this.
  4. kilomonk

    kilomonk New Member

    I have a week old Death Adder Elite that I was very happy with until now. Same issue here with last update10.13.4 Beta (17E150g). Can't easily roll these back. Now just a regular mouse. Side buttons no longer function and app won't open to allow configuration. Maybe Razer will bring Synapse 3 to mac?

    Meanwhile, any workaround?

    Using an older Macbook Pro, so I need every advantage...

    I sent a bug report to Apple.
     
    Last edited by a moderator: Oct 17, 2018 at 7:51 AM
  5. franctastic

    franctastic Member

    It's a beta, but it's already version 4
    10.13.4

    Razer has the problem with Apple device users, not Apple with its macOS.

    To me, personally, Synapse gives me a lot of problems, and I am in permanent contact with the technical service of Razer....

    salut!

    opens Activity Monitor, force quit RzDeviceEngine and reopens Synapse, until your profile is loaded (not always working the first time)

    there are more alternatives, but this way is simple

    salut!

    Deshabilitar Synapse para cargar al inicio con Lingon X

    /Library/LaunchAgents/com.razer.rzupdater.plist
    /Library/LaunchAgents/com.razerzone.rzdeviceengine.plist

    salut!

    hahahahaha :confused_:
    no :mad_:
     
    Last edited by a moderator: Oct 17, 2018 at 7:51 AM
    easyjay39402 and Rem490 like this.
  6. glig69

    glig69 New Member

    Why the heck does the RzDeviceEngine process need 2GB memory on my iMac? For a mouse driver? Come on, this is nonsense Razer. Look at your ActivityMonitor next time, and you'll be amazed.
     
    Last edited: Feb 18, 2018
    dj_jump1011 and BaccaBoss2 like this.
  7. franctastic

    franctastic Member

    for when the update for macOS High Sierra?

    Synapse 1.82 does not work with the latest macOS High Sierra version

    CRASH!

    salut!
     
    Bosuil likes this.
  8. NewCarhithome256

    NewCarhithome256 New Member

    New Macbook Pro 13inch, installed the software for Razer Naga Molten and when I left click on link in browser it opens the link in new tab, when I left click on the tab, it closes it.
     
  9. franctastic

    franctastic Member

    in terminal, either of the two options works.

    killall RzDeviceEngine
    killall RzUpdater

    I have created a APP to close the two Synapse processes

    salut!

    Hello, Razer developers.
    in case you guys haven't been paying attention, Apple has uploaded today (February 21) the latest update of macOS High Sierra to version 10.13.4

    Synapse still doesn't work...
    crash!

    for when the required update of Synapse?
    Synapse version 1.82 causes a lot of crashes, problems and errors
    I haven't used Synapse since two weeks!

    I'm indignant at Razer.

    salut!
     
    Last edited by a moderator: Oct 17, 2018 at 7:51 AM
    dj_jump1011 likes this.
  10. Zorn_

    Zorn_ Active Member

    Same here, not able to even run Synapse.
     
    franctastic likes this.
  11. franctastic

    franctastic Member

    hello developers, need help updating Synapse?

    CRASH!

    the Synapse Problems affect me a lot in my work.

    THX in advance
     
  12. Anyone found a solution yet?
     
  13. sebastar

    sebastar New Member

    For me it was even worse... I installed the "Razer_Synapse_Mac_Driver_v1.82.dmg" on my mac and after a reboot, my computer would not even finish booting. I had to go to an apple store and hopefully they manage to kill the drivers and start my computer again.
    Please let me know when a driver make it possible to use my tartarus Chroma to play... for now I'm just looking at it unable to use it...
     
  14. Bosuil

    Bosuil New Member

    Synapse for Mac, sucks big time
     
  15. msymms

    msymms New Member

    Yep, tried to install it last night. Now my Mac running released High Sierra will not boot. Could not even get it to boot in safe mode. Will try a recovery tonight. This is ridiculous.
     
  16. Bosuil

    Bosuil New Member

    Wy does Razer not adres this issue?
     
  17. msymms

    msymms New Member

    I guess Mac users are not a market they target fully. Seems more like an afterthought. I just have to get my system up so I can uninstall.
     
  18. franctastic

    franctastic Member

    I haven't been able to use Synapse in three weeks

    salut!

    deletes the files plist, with Terminal, from recovery mode

    /Library/LaunchAgents/com.razer.rzupdater.plist
    /Library/LaunchAgents/com.razerzone.rzdeviceengine.plist

    [​IMG]

    salut!
     
    Last edited by a moderator: Oct 17, 2018 at 7:52 AM
  19. sebastar

    sebastar New Member

    which version of high sierra did you have?
    anyone tried on the newer version 10.13.3 ?
     
  20. franctastic

    franctastic Member

    I use the version macOS High Sierra 10.13.4 beta 3 (17E160e)

    salut!

    how much time wasted with Razer...

    Because of the problems I have with not being able to use the buttons on my beloved mouse "Razer Naga Epic Chroma", I have looked for an alternative while Synapse does not work on macOS High Sierra.
    I installed software to replace Synapse: SteerMouse

    [​IMG]

    What's SteerMouse?
    SteerMouse is a utility that lets you freely customize buttons, wheels and cursor speed. Both USB and Bluetooth mice are supported, no matter whether the mouse is designed for Windows or Mac.
    http://plentycom.jp/en/steermouse/index.html

    Obviously, there's a problem with the driver:

    [​IMG]

    This may be due to the following driver If your mouse does not work.
    Please contact the manufacturer how to uninstall it.

    /Library/Extensions/RazerHid.kext
    (com.razer.common.razerhid)

    I request help from Razer developers

    THX

    I have written to the developers and I suppose they will answer me.

    I'll let you know if there are any news.

    salut!
     
    Last edited by a moderator: Oct 17, 2018 at 7:52 AM
    cshark95 likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >