Razer Synapse 2.0 on macOS High Sierra issue

Discussion in 'Razer Synapse' started by RADIUMU92-SSBPLASMA, Feb 6, 2018.

  1. cshark95

    cshark95 New Member

    I'm on 1.83 and your POS software still glitches. Literally about to reach out to all Tech PR outlets and get you a sh*t show of bad press if this isn't fixed asap.
     
    BaccaBoss2 likes this.
  2. Oh boy, gonna sell my 3h old crap/hardware (Tartarus V2). No joy.

    MacOS High Sierra 10.13.6.
     
  3. Note: MacOS only: I just upgraded to a MBP 2018/10.13.6 and as usual have issues with Synapse. There is a post on the WoW Forums that may help get many of us back up and running. No guarantees, but I have my faithful Naga Epic running again. Search the Mac forums for "mouse shift, Alt, Ctrl not working" look for a comment posted by Dordric. I hope to see some of you in game...

    BTW - I joined to make this post and was randomly given a completely heinous profile name... :slightly_sad:
     
  4. azriaba

    azriaba New Member

    So I've been reading this thread before deciding to buy the Ornata Chroma, which filled with doubts. However, after finding a really good deal in store and reading some reviews, I decided to buy it anyway.

    Here's the specs of my mac:
    • MacBook Pro (13-inch, 2017)
    • macOS Mojave 10.14.2 (18C54)
    I then downloaded Synapse 2.0 from https://www2.razer.com/ap-en/synapse-2 for Mac OS. Interestingly, the software version in Settings shows that it's 1.85.2. After installing, I followed these steps (may not be in order):
    • Press Allow in Security preferences.
      • I preemptively turned off BetterSnapTool because previously I had an issue after installing Logitech's software; I wasn't able to click Allow because of the assumed possibility that the app may simulate clicks.
    • Restart mac.
    • Allow RzDeviceEngine to control computer in Security Privacy preferences.
      • Basically I followed the instruction shown when Synapse was run the first time.
    • Create a new Razer account.
    • Login & connect my keyboard.
    At this point, Synapse detected the keyboard and started downloading stuff. Then, my keyboard lit up with the Spectrum Cycling effect. I was thrilled at this point & then tried to select other effects...but nothing seemed to change. I quit the app & plugged out the keyboard. Then, I plugged it back in & started Synapse again. This time, the Customize tab was showing the keyboard (it wasn't showing the first time around) & changing the lighting modes worked.

    The best part for me was I was able to swap the alt (option) & windows (command) key functionality in Preferences > Keyboard > Modifier Keys... > Razer Ornata Crhoma. So, it works just like a mac layout - albeit still physically windows & without the fn key on the left of the spacebar.

    Long story short, Synapse seems to be working fine for me. And now, I'm typing this on my Ornata Chroma. So, I guess it was a pretty good gamble for me. Hope it stays this way.

    ~Happy New Year 2019~
     
  5. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Thanks for sharing, @azriaba! I'm glad that it's working out for you.

    Now for a real honest heads up: as I'm sure you've discovered, you won't be able to do EVERYTHING with your Ornata Chroma on Mac OS as you would be able to on Windows. I think the packaging would have even had one of those asterisks next to some of the features, sayng this. So good on you for hanging in there anyway.

    If you are ever prompted to update the software, do yourself a favour and save the installer file. Do this by NOT updating through Synapse, but going to the Synapse page and downloading the newest version from there (then uninstall Synapse and re-install the new one). I say this because there will inevitably come an update that causes your Ornata Chroma to lose some of the functionality that you're enjoying now, and after submitting a bug report, you'll be able to just go back and install a previous version. Heck, you might want to even re-download the current installer just in case you don't like the next update. I, personally, have all the Mac-Synapse versions going back a couple of years.

    My only other suggestion is to work in "offline mode" when you can. To put it simply, it should help keep everything stable WHILE you're using it

    Hope this helps!
     
  6. awsom82

    awsom82 New Member

    Very strange software. And very strange that Razer dint even comments here. I enjoy my Deathadder. But when I install mac software I am was aware it's not in app store, and require a reboot -- that's totally unacceptable for mac software. So, Synapse work, but dint see my mouse. Total waste. I plan to get tartrus v2 and sila router. but fear bad software.
     
    Last edited: Jan 13, 2019
  7. Goosebuster

    Goosebuster New Member

    Wish I would have seen this thread before buying the Ornata.

    The "Razor USA Ltd." doesn't show in System Preferences->Privacy. The "Allow" button is there but no software to allow. I've added "Razer Synaps" to the app list of software that's allowed to control my computer.

    What do I do now? More restarts than I can count at this point but the dang "Razor USA" won't show.
     
  8. Goosebuster

    Goosebuster New Member

    Just insane but this did the trick:
    https://apple.stackexchange.com/questions/323668/allow-button-not-working-in-system-preferences
     
  9. ajaynarainmathur

    ajaynarainmathur New Member

    I just bought a Razer BlackWidow elite but it is not recognised by Razer Synapse 2.0 software on my mac.

    Is there a way to make it work so that I can configure the keyboard or should I just return it?
     
  10. soloBeaverpulse554

    soloBeaverpulse554 New Member

    Same issue, Razer listen to your customers :mad_:
     

    Attached Files:

  11. BenjaminStackin

    BenjaminStackin New Member

    I have the same issue as most people in this thread. I bought a Mamba thinking that I could use it with my Mac, and while technically I can, the software refuses to recognize the device. So, that means I can't program any of the keys or change the lighting, or just take full advantage of the mouse. Really frustrating, Razer...
     
  12. ReCkLeSsRoSs710

    ReCkLeSsRoSs710 New Member

    so my synapse software loads up and lets me login in, im using the keyboard rn. but synapse doesn't say its connected. ive tried everything in this tread, thinking about taking it back and getting the new alienware keyboard.
     
  13. The_dead

    The_dead New Member

    "Please connect a Razer Synapse enabled device"

    Please help, I am on mac pro 2018 touchbar mojave
     
  14. I bought 2 Razer mouse, Neither of them works well since beginning of 2018. The Mamba one just says: "Please connect a Razer Synapse enabled device". I will throw them rubbish can once I get my Logitech Master 2S.
     
  15. BaccaBoss2

    BaccaBoss2 Active Member

    Delete Synapse and reinstall. That often fixes issues for a few weeks.
     
  16. KatsumotoX

    KatsumotoX New Member

    Just bought a new Razer Huntsman Elite just to notice that this lovely piece of tech is not getting recognized by the Synapse App on my MBP 2018 i9.

    Sadly I found this thread too late - guess it's gonna be a return due to the fact that Razer obviously doesn't give a sheit about there OSX users.

    Thanks for that.
     
    BaccaBoss2 likes this.
  17. Thank you.
    I tried to uninstall/install many times(1.84, 1.85). Every time after MacMini is restarted, I have to reconnect the USB cable, otherwise, it says: "Please connect a Razer Synapse enabled device".
    Reconnecting the USB can make the Razer Synapse recognize my mouse, but I don't want to reconnect it every day.
    [​IMG]
    Seems the great Razer team doesn't care these issues at all, sadly.
     
    Last edited: May 6, 2019
    BaccaBoss2 likes this.

  18. I have another the DeathAdder + MacBook Pro (13-inch, 2017, Two Thunderbolt 3 ports). The Synapse doesn't work in another way. Uninstall/reinstall doesn't help

    [​IMG]
     
  19. I have a Deathadder Elite and when I try and play League of Legends using the mouse software my mouse constantly spazzes out. The only thing that somewhat helped was turning the Polling Rate from 500 to 125, but still has not 100% fixed the issue. This issue only happens in game and not anywhere else on the computer. I am running MacOS High Sierra 10.13.6 and Synapse says there are no updates and is on Version 1.85.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >