Razer Synapse 2.0 on macOS High Sierra issue

Discussion in 'Razer Synapse' started by RADIUMU92-SSBPLASMA, Feb 6, 2018.

  1. YTNickman

    YTNickman New Member

    Does anyone have a fix to the program just keep loading
     
  2. JAKEG2008

    JAKEG2008 New Member

    I agree with you.
     
  3. Ricky1488

    Ricky1488 New Member

    I am having the same issue to detect my Huntman Elite keyboard and Mamba Elite. I have tried different solutions and none of them worked-
     
  4. PT.Singer

    PT.Singer Jedi Master VANGUARD

    They are not compatible with Synapse 2 for Mac.
     
  5. Ricky1488

    Ricky1488 New Member

    So, there is no way that I can setup on MAC?
     
  6. zcWoW

    zcWoW New Member

    that is correct
     
  7. PT.Singer

    PT.Singer Jedi Master VANGUARD

    There is no way to set up the customization as far as keybinds, macros, or lighting. The keyboard and mouse should still function as a normal keyboard or mouse.
     
  8. zcWoW

    zcWoW New Member

    Shift/ctrl + razer naga mouse keypad does not work. Can verify after 6 hours today and multiple calls with customer service.
     
  9. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Honestly, I can't get that to work even on Synapse 2 on my Naga Epic Chroma. What I've found is that as soon as you press one of the buttons on the side of the Naga, it pretty much cancels out any other keyboard press that's going on.

    The workaround that I've figured out is to actually map Shift/Ctrl to another mouse button (one of the ones on top of the Naga, or even the tilt-clicks). Then if you press that other mouse button with the Naga side button, you get the modifier effects.

    Of course, if you're using a mouse that doesn't work with Synapse 2 for Mac and you're trying to do it on a Mac, then you can't do that.

    But the issue that you're having is not a Synapse issue. It's an issue with the way the commands are actually being sent from side buttons of the mouse itself. I don't have an answer for that.
     
  10. zcWoW

    zcWoW New Member

    Bought a Huntsman elite.... wasn't compatible. Customer Service told me Black widow was compatible, I went return my huntsman and bought a black widow and now it isn't being recognized by synapse. I understand what you mean by binding other keys but the principal is that I am not paying almost 2 bills to have a half working product. It is just mind boggling that they aren't being straight forward with a pretty large customer base.
     
  11. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Oh no. Which BlackWidow? The new one (just called the BlackWidow) isn't compatible. I think that one, the BlackWidow Elite, and the Blackwidow Lite are the only ones that AREN'T compatible with Synapse 2 for Mac.

    I'm sorry that you were misinformed.

    Here is a link to all Razer devices that are compatible with Synapse 2 for Mac OS (version 1.86). I know that it lists the Razer BlackWidow on here, but I think that it is referring to the original BlackWidow keyboard, and definitely NOT the new one.
     
  12. zcWoW

    zcWoW New Member

    Yeah learned the hard way, even though BlackWidow is on the list, it is NOT compatible. I bought the brand new one and will have to return it tomorrow in exchange for a Corsair.
     
  13. PT.Singer

    PT.Singer Jedi Master VANGUARD

    That's a bummer (because I love Razer and hate to see people go elsewhere for their gaming needs). Have you looked into the BlackWidow Chroma v2?
     
  14. 301105

    301105 New Member

    Hello guys,

    I just bought a Razer Huntsman keyboard from my friends and also downloaded Synapse 2.0. However after logging in the screen just says "Please connect a Razer Synapse enabled device". I have tried uninstalling Synapse however I have come to the same result. I have registered my keyboard in my razer ID and I have tried everything but it just doesn't work. My friends said that it worked for them but not me.

    I am operating on macOS High Sierra Version 10.14

    Please help!
     
    jgasp002 likes this.
  15. zcWoW

    zcWoW New Member

    My man...

    I had the same thing happen with my Mac. After much frustration and getting told wrong info by customer support I found out that only certain older models work with synapse 2.0. There is a list of models that work with it somewhere on this forum or online. I finally jumped ship and went with corsair and haven’t looked back since. Best of luck.

    PS

    It has been an issue for a very long time and from the looks on this and other forums, it seems razer personnel have been committed to ignoring the apple user base.
     
  16. jgasp002

    jgasp002 New Member

    I am having the same problem everyone has. It says "please connect a razer synapse enabled device." :slightly_sad: The number pad on the right is completely useless. I am probably going to return this keyboard for something that works. Just for reference, today is 9/4/2019.
     
  17. sham.bam

    sham.bam New Member

    Did you find out a way to fix it because I'm in the exact same position as you.
     
  18. NashTheFlash

    NashTheFlash New Member

    2019 turning to 2020 - and still its shit for mac-users. I remember in the 1990-s "mac-user" was a rare fenomena, but today?
     
  19. ElfMusicOfficial

    ElfMusicOfficial New Member

    Figured it out guys! It kept saying right command and not assigning shit to any key like everyone was talking about.

    Solution: Hold down the function you wish to use. DO NOT let up on it and then press okay with your mouse.

    Example i wanted to assign it arrow keys so I held the arrow key continuously while selecting OK
    BOOM key has been assigned to the arrow key. I will do this for the rest of my custom functions i wish to assign to my keys. Idk if this helps tech support but its a start.

    I am running the lastest macbook software 10/29/2019
     
  20. ElfMusicOfficial

    ElfMusicOfficial New Member

    I did
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >