Razer synapse 2.0 with Razer Electra V2 USB

Discussion in 'Razer Support' started by PCGamer231231, Apr 27, 2019.

Thread Status:
Not open for further replies.
  1. PCGamer231231

    PCGamer231231 New Member

    Hello, everyone!

    Recently I have purchased the great If not amazing headset called Razer Electra V2 USB.
    Now I've Installed the synapse 2.0 and everything etc but I've checked through task manager, and couldn't believe what I see.. while using the razer synapse 2.0 WITH the supported headset plugged In, It will use roughly around 35% CPU!! Just for having 7.1 enabled and all the other settings.

    I don't know If this Is the same for other headsets and I don't know If this got fixed completely In synapse 3.0 but I call for all the staff that might see this right now, Please fix this ASAP! It Is simply absurd to have this such high Impact on CPU because obviously you will want the synapse to be open 24/7 as you want to use that high quality 7.1 on games etc

    I've tested this several times and I'm quite sure that It Is using 35% because of the razer synapse because when I un-plug my headset from my computer the CPU usuage comes back as It used and should be.
    The process named "Razer Synapse" seems to be using only 10% CPU at MAX but the big downgrade comes from the process named "Windows driver foundation - User-mode Driver framework Host Process".

    So with both of these sucking up the CPU It can go up to almost 40% usage! JUST by having the razer synapse with your headset plugged In.. It's simply crazy..


    Thanks In advance to anyone who can help!
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Can you PM me the serial number of your Electra V2 USB? Please make sure to include the link to this thread. I'll assist you from there.
     
    PCGamer231231 likes this.
  3. PCGamer231231

    PCGamer231231 New Member

    There's no need for that.
    Because 2 days ago I reached out to the live chat support and got help but the Issue Is not resolved because the live support agent told me that all the Information I have provided will be sent to the Internal developers of razer synapse and they will send me an email In about 24-48 hours.

    Sadly It has been 2 days now so It should be around time more or less, I'm expecting for a response today.
     
  4. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Thanks for letting me know. Can you send over the case number through PM so I can check on your case? Please include the link to this thread as well. I'll pick it up from there.
     
    PCGamer231231 likes this.
  5. PCGamer231231

    PCGamer231231 New Member

    Sure! doing so right now.
    And thank you so much btw! I really appreciate this.
     
  6. PCGamer231231

    PCGamer231231 New Member

    Bumping this up.
    Everyone seem to have this EXACT problem and for over half a year now.
    Razer seems to Ignore/lie and never actually check this and fix this problem once and for all.

    Threads for example: 1. https://insider.razer.com/index.php...cpu-usage-when-using-razer-synapse-2-0.45203/

    2. https://insider.razer.com/index.php?threads/windows-driver-foundation-100-cpu-usage.47286/


    There is no need to hide razer, either make ALLLLL YOUR PRODUCTS FINALLY support razer synapse 3.0 or fix the Issue on synapse 2.0 forever.. because It's here for years and many many users are having this.
     
  7. SpiderCarnage

    SpiderCarnage New Member

    Hate to tell you, but this wont go away with having "only" Synapse 3 installed. I tried.
     
  8. PCGamer231231

    PCGamer231231 New Member

    Damn that's very bad then...
    So razer never gonna fix this like wtf?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >