Razer Synapse 2.0 won't open

Discussion in 'Razer Support' started by ZionCrix, Aug 9, 2019.

Thread Status:
Not open for further replies.
  1. ZionCrix

    ZionCrix New Member

    Just Installed razer synapse 2.0 today as i just bought razer kraken 7.1 and after keying in my razer ID, razer synapse update manager started updating. Afterwards, it showed "syncing settings from the cloud" then it disappeared. I tried to open it up from the tray but it won't open. I have uninstalled and reinstalled synapse but the problem persists.

    Please help me solve this. Thank you.
     
  2. MikeYeet

    MikeYeet New Member

    i'm having the same issue, tried to talk to customer support, never quickly responds me, and ditched me because i went to washroom for 2 mins. the guy doesn't even reply in 2 mins
     
  3. Rosewoodleettech428

    Rosewoodleettech428 New Member

    Same was on chat with them for 30 minutes. Only thing achieved was me confirming my email address. Useless service.
     
  4. Rosewoodleettech428

    Rosewoodleettech428 New Member

    This is nuts. I had it working but it wouldn't see my new Naga so I uninstalled old and installed new 3. It saw the naga lost my chroma. Tried to install old again, now I got nothing.
     
  5. Swollen_beef

    Swollen_beef New Member

    I have had this issue as well. I have uninstalled and re-installed twice now. After installation the software (synapse) works perfectly for about 5 days. After approx a week synapse stops responding. opening the software brings up a window that is clearly my account settings. Things like Password, Email, User name, etc. standard account info stuff. But i cannot leave that window. after leaving this window up for about 90 seconds, it automatically closes and prompts me to log in. logging in does nothing except leave the log in window up. It cannot be closed, it cannot be forcibly closed through task manager. it welds itself to my desktop and will not allow any further use of the computer.
    A reboot is required to regain control of the computer.
    unfortunately i have abandoned all of my razer products due to the poor construction of synapse.
    I did not contact tech support regarding this issue. I did not feel it was necessary to jump through the standard help desk hoops such as reboot, re-install. These steps have already been completed and would be of no help at this point.
     
  6. ZionCrix

    ZionCrix New Member

    it still isnt working... i tried for a few times now and yet it just refused to work.
     
  7. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi guys! Please PM me the version number of Synapse. I'll assist you from there.
     
  8. ZionCrix

    ZionCrix New Member

    i have DMed you :D pls have a look at it at your own convenience.
     
  9. Hatespirit

    Hatespirit New Member

    I just purchased a Razor Deathadder Chroma, i cannot register it on the website, i cannot use the synapse software, it won't open. Any fix for this?
     
  10. freshSienna922

    freshSienna922 New Member

    Same problem here! Someone got it fixed already?
     
  11. tenXring

    tenXring New Member

    I just bought a blackwidow elite both mouse (naga trinity) and keyboard are working but synapse doesn't open. Get your life together dev team... and help us plx :D XOXO
    Synapse Version:
    2.21.24.1
     
  12. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi guys! Please send me a PM. I'll assist you from there.
     
  13. THECHATTERBOX20

    THECHATTERBOX20 New Member

    Got this problem also with my kraken 7.1
     
  14. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! I have responded to your PM. Let's continue there.
     
  15. hi i also bought a razer kraken 2019 a few days back and i am having the same issues as zion the OP
     
  16. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! I have replied to your PM. Let's continue there.

    Anyone else having the same issue, please do PM me instead.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >