Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Synapse 2.21 Not Recognizing My Blackwidow Chroma RZ03-0122

Discussion in 'Razer Support' started by That-One-Other-Guy, Jul 3, 2020.

Thread Status:
Not open for further replies.
  1. That-One-Other-Guy

    That-One-Other-Guy New Member

    As stated the Razer Synapse 2.21 is not Recognizing My Blackwidow Chroma (RZ03-0122)

    It wasn't recognizing my Keyboard for a while, but as I am getting back into gaming I need to get this fixed.Also this is the only Razer product I own.

    Things I tried:
    • Confirmed the USB Settings in the device Manager
    • Tried changing the USB ports power settings
    • Tried updating the USB Drivers and all drivers in general
    • Rebooted multiple times.
    • Killed all Rezer tasks in the device manager and then restarted the Razer Synapse
    • Ran a SFC Scan
    I'm Kinda out of ideas and about all the threads I see on hear move to PMs for more info so I am not sure what else can be done.

    Thanks in advance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >