Razer Synapse 2 and 3 Sign In problem (Oh snap! Something went wrong just now. Please try again.), (

Discussion in 'Razer Support' started by idkFeyzr, Mar 4, 2019.

Thread Status:
Not open for further replies.
  1. idkFeyzr

    idkFeyzr New Member

    Hello, 3 days ago I've encountered a problem with my Synapse software.I wanted to import a lighting profile and I've gotten an error saying I have to be online to do so(which I thought I was).Upon "going online" the whole application kinda went not-responding but after a couple of mins it logged in.



    Later that night I wanted to try the Synapse 3 but I've uninstalled the Synapse 2 thinking it might cause some problems.After installing the 3 I wasn't able to log in so I wanted to switch back to the 2 , and that's when my misery began. So , on the Synapse 2 I'm getting an error "NETWORK NOT AVAILABLE" after the "VERIFYING YOUR ACCOUNT " runs out, and the error on the 3 was something in terms of "we're having issues with our server please try again" , and after getting the 40MB update of the Synapse 3 , the error switched to "oh snap,something went wrong please try again".



    The solutions I've tried but haven't worked are: 1.Disabling the antivirus 2.Adding the firewall exception to the synapse. 3.Reinstalling the Synapse(both 2 and 3) 4.Trying different versions of the Synapse 2 5.Resetting the password of my razer account(I can log in on the razer webpage)
     
    Sparkwork likes this.
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Hi @idkFeyzr. Just checking in. Are you still experiencing this issue? If so, please send me a PM so we can try to further isolate.
     
  3. Sparkwork

    Sparkwork New Member

    I'm having the same problem, I've already uninstalled and reinstalled all razer software.
     
  4. nerzki

    nerzki New Member

    I'm getting the same error. Any fix yet?
     
  5. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @Sparkwork and @nerzki, please send me a PM so I can help you gather the necessary logs. We'd need those to see why you're getting the error.
     
  6. BigTex9012

    BigTex9012 New Member

    I'm having this issue as well!
     
  7. butlerist

    butlerist New Member

    I'm also having this issue
     
  8. Gribox2019

    Gribox2019 New Member

    Please I'm having the same problem.
     
  9. TinyTemper13

    TinyTemper13 New Member

    hello i am having the same issue, I have alreay reinstalled the hardware drivers
     
  10. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    To everyone else experiencing this, please send me a PM so I can help you start a ticket. We'll also need your logs so we can put up a proper hotfix for this.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >