Razer Synapse 3.0 Broken

Discussion in 'Razer Synapse 3 Beta' started by DerpyWerpy, Jul 18, 2018.

Thread Status:
Not open for further replies.
  1. DerpyWerpy

    DerpyWerpy New Member

    Hello.

    I run Razer Synapse as administrator
    A black box pops up in the middle of my desktop
    The box has no contents but a green circle where the logo is supposed to be
    It also says "retry" and underneath is a hidden text "get help" only seen when hovered over with cursor
    Clicking "get help" just takes me to Razer Support page and crashes Microsoft Edge
    Have to exit the black box window to close Microsoft Edge

    This is a clean installation of Windows 10 and was running just fine before hand (besides the army of bugs)
    I really need help fixing this! Thanks.
     
    Allsome likes this.
  2. DerpyWerpy

    DerpyWerpy New Member

    I decided to upload an image showing the issue. Screenshot (1).png
    Help needed! So confused :s
     
  3. DerpyWerpy

    DerpyWerpy New Member

    Hello again with the quick updates!
    I found a fix for myself and those who are also confused :s

    Go to Settings > Apps > Razer Synapse
    Select uninstall and when given the option click "modify - updates available!" within the Razer window. Proceed with the update process and the issue should be solved. Razer Synapse will work again.

    Image provided =)
    Screenshot (3).png
     
  4. P5tY4sKhzz6a8

    P5tY4sKhzz6a8 New Member

    Well, your solution looked promising, as I had (have) the same problem. However, the installation of the update gets to 99% and stops for about 40 seconds, then goes back to 80% and repeats the process. :slightly_sad:

    Any more ideas that may help?
     
  5. Wolf_Lone

    Wolf_Lone New Member

    I would recommend a good old fashion delete and reinstall instead of updating as razer cloud sync your stuff anyways
     
  6. DerpyWerpy

    DerpyWerpy New Member

    Go to task manager and end all Razer applications then try the steps provided maybe? :stuck_out_tongue_winking_eye:
    Also, disconnect your Razer Devices USB's from your computer ports and then plug them back in?
    One last thing which I do not know if it has any effect, but to switch of your PSU when your PC is fully shut down.
    I know that some apps like to store data in RAM so that was the reasoning behind that last idea.

    I attempt a re-install and that did not help either. The Razer Cloud appears very buggy in my experience and doesn't always correctly download my profiles again. Sometimes I'd end up with 20x "default" profiles I never had before.

    The steps I shown worked for me so hopefully some of the ideas will help you with your problem too :s
     
  7. Giolon

    Giolon New Member

    A new update came out last night that is full of bug fixes, so I'd advise anyone who was having problems with Synapse to update to the latest version
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >