razer synapse 3.0 server access unavailable

Discussion in 'Razer Synapse 3 Beta' started by yogiassadi, May 2, 2019.

Thread Status:
Not open for further replies.
  1. yogiassadi

    yogiassadi New Member

    hi im having a problem installing new synapse 3.0

    im using 2.0 and whenever i tried to click the update it shows me that the software updated.
    so i took initiative to uninstall 2.0 and try to install 3.0

    as you can see the title it keep shows me Server access unavailable.
    tried to smash the retry button but it didn't work.

    need some clarity here.
     

    Attached Files:

  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    Yeah in synapse 3 install most people have this issue but when retray it's pressed downloading start again . I can only recommend tou disable antivirus and firewall on your pc to make sure it dont block the connection you also cheack if you dont have locked ports on your router.
     
  3. yogiassadi

    yogiassadi New Member

    ive been retrying download for almost 4 hours and it always stuck.
    already disable antivirus & firewall. i don't have locked ports on my router. tried download on vpn and didn't work as well.

    now im sticking with my 2.0. is razer Nari worked in 2.0?
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    It looks like something block the connection to tthe server. It hard to say what is it but if have another device/pc try there you see if the issue is on your pc or in network.
     
  5. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hello @yogiassadi. Can you PM me a screenshot of your Allowed apps and features list in your Windows Defender Firewall? Let's continue there.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >