Razer Synapse 3.0 Update Broke Macros

Discussion in 'Razer Support' started by bvnnd, Dec 19, 2020.

Thread Status:
Not open for further replies.
  1. bvnnd

    bvnnd New Member

    I've set many macros for many utilities for years now, they was working as a charm, but since the last Synapse 3.0 update most timings are totally broken or either don't work at all
    especially when the using the "play while assigned key is pressed" with a no delay macro or with 0.01
    (and they was working just perfectly before)
    I want to know if their is any way to downgrade Razer Synapse 3 Update or either have a fix from Razer.
    3.5.1215.121019 Is the version that have problems
     
  2. Siphin5150

    Siphin5150 New Member

    I had to go into Unistall/Remove program, select modify and update. Then after doing so I ran synapse as admin and it fixed all my broken macros and keybinds. Hope this helps you.
     
    SilentScr3am likes this.
  3. bitAcidGreenbuzz791

    bitAcidGreenbuzz791 New Member

    SAME PROBLEM I CANT USE MY MOUSE NOW. NOW IS A 1 USD MOUSE FOR ME.
     
    SilentScr3am likes this.
  4. trrzq.f

    trrzq.f New Member

    I have an issue after recent update of Razer Synapse 3.0 (version 3.5.1215.121019). Macroses which have been already written started to fail. Every time I use them they fail some part of timings, I tried to write them again, but there was the same problem. What should I do to fix it? Numerate all possible variants please. This Synapse patch ruined me days off.
     
    SilentScr3am likes this.
  5. JupiterRZR

    JupiterRZR New Member

    I'm just now experiencing issues like this, it's ruined my mood today since I use macros everyday when playing... I hope they fix this. I've tested a left click macro (after update) in Minecraft and I've noticed that using it it starts to lag the mouse a crap ton as it seems like it's being overflown by activation stuff. It NEVER did this until this morning that it automatically updated my Synapse 3 software. I'm assuming they changed how fast the mouse spits out macro looping to the point that it's too fast for a game to pick it up.
     
    SilentScr3am likes this.
  6. bvnnd

    bvnnd New Member

    That exactly what i am experiencing, i'm in contact with escelation support team they are investigating this
     
    SilentScr3am likes this.
  7. SilentScr3am

    SilentScr3am New Member

    I'm on the same boat as you guys, that's just sad, never gonna update again after they fix this issue
     
  8. ElricDsharp

    ElricDsharp New Member

    I don't know if this is the same situation for for you or anyone else. But i ran their most recent update todat (2020.12.21) and after rebooting, not only was synapse not recognize my Keyboard, Mouse [basically everything i run is razor] but it wouldn't register them after unplugging them or rebooting my pc, my macro were also gone. However, I believe I found a fix or maybe its just me anyways, couldn't hurt to mention it. I went directly into the Windows settings > Apps & features > Razer Synapse > Modify. It opens up a razer Uninstall interface, where u choose between, Modify, Remove software, uninstall. I chose Modify, then it says update available, so i just ran the update. I didn't Select or Deselect anything. Once it was done, synapse just went back to normal. So maybe its worth a try for you. If it works, pass it on.
     
  9. CarlosGG22

    CarlosGG22 New Member

    Same problem, all macros that i created are broken, will they fix it?
     
    SilentScr3am likes this.
  10. trrzq.f

    trrzq.f New Member

    Bruh, and what the exact number of update is it now ?
     
  11. Hottopedia

    Hottopedia New Member

    Même problème ici.
     
  12. tomwarren

    tomwarren New Member

    I'm also having issues with the latest update.
     
  13. Fricken

    Fricken New Member

    By me it sounds like macro work if i bind them on any key ; but i m used to use them in Hypershift mod and it looks like the FN key is some kind of not working ....

    It's registered as pressed by the keyboard (lights changes) but and when i use a key where i bound a macro it simply doesnt work exemple fn + numpad 1 should be mail adress ---> instead it's just 1....

    I tried to repair installation ; ried a brand new fresh instalation ; redone some macros ,nothing worked
     
  14. Blueberry_666

    Blueberry_666 New Member

    Any luck fixing "play while assigned key is pressed"? I have bought brand new DeathAdder v2 solely because of macors and now they are not working, FFS
     
  15. trrzq.f

    trrzq.f New Member

    So, are there any changes with RAZER SYNAPSE 3 update? My macro still goes bad, lagging, problems with switches etc.
    Maybe Razer boys and girls can answer us what can we expect?
    I'm SO DISSAPOINTED!
    Pls
     
  16. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi trrzq.f! Have you replicated the issue by logging in as a guest user and creating a test macro?

    Hey everyone! Sorry for the inconvenience. I've notified our team regarding the software's behavior. Please help submit a case with your Razer Synapse 3.0 logs. Save the files via Google Drive or to any online drive, then paste the link in your PM. Let's continue our conversation there. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >