Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Synapse 3 Failed to Start. Server Access Unavailable

Discussion in 'Razer Synapse 3 Beta' started by ws.yuri, Sep 15, 2019.

Thread Status:
Not open for further replies.
  1. ws.yuri

    ws.yuri New Member

    I got a new Alienware Desktop in April, but never got Synapse 3 working on it. I've had Razer products for years, the Synapse 3 worked on my old Desktop & Blade, but not the new one. Alternatively, i have to use Synapse 2, but now i got a new Mamba Wireless which only works with 3. I've tried solutions posted by others, such as updating system and software; uninstall everything and reinstall it; Using "repair" to fix the program; disconnect all Razer products as suggested in "Help". NONE of them works. I noticed every time i do a fresh installation, it will stop at about 90% and says "Server Access unavailable", but it will continue working if I click "retry". (i already tried to allow it as an inbound rule in "Firewall with Advanced Security", same result). So I tried to open "Razer Central.exe", it won't connect/work unless I open "RazerCentralService.exe" first. After I open "Razer Central.exe", in the "APPS", it cannot detect installed Synapse 3. If I click "Install", it seems it cannot connect (see attachments).
    I have the latest Win 10, and Synapse 3. Anti-virus and firewall are both off. Anyone has a solution? thank you in advance.
    [​IMG][​IMG][​IMG]
     

    Attached Files:

  2. Kwokim

    Kwokim New Member

    Same problem here.
     
  3. osuandrew87

    osuandrew87 New Member

    im having the same problem about to return this crap
     
  4. luizvictorqueiroz

    luizvictorqueiroz New Member

    Same problem here.
    DM at twitter but they keep replying to do the same thing.
    upload_2019-11-5_20-21-8.png
     
  5. Petite0819

    Petite0819 New Member

    same here...
    it happens after window 10 update and RAZER SYNAPSE version 3 and COTEX updates.
     

    Attached Files:

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >