Razer Synapse 3 failing to install

Discussion in 'Razer Support' started by AeroTheFox05, Jul 12, 2021.

Thread Status:
Not open for further replies.
  1. AeroTheFox05

    AeroTheFox05 New Member

    Hi. I have a Razer Kraken BT Kitty Edition headset, and I'm trying to get Razer Synapse working on my PC. For some reason, whenever I try to install Synapse, it fails. I've tried clean installing, I've tried using a different installer, it always fails. Any help?

    PC:
    OS: Microsoft Windows 11 (Build 22000.65)
    CPU: Intel Core i7-1065G7
    GPU: Intel Iris Plus Graphics
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Can you send me a short video clip or a screenshot of what happens when you try to run the installer? I'd also appreciate it if you can send me a screenshot of your MSINFO32 as well so I can check for possible platform issues.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >