Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Synapse 3 Install Error

Discussion in 'Razer Support' started by SI1802H04803734, Jul 7, 2020.

Thread Status:
Not open for further replies.
  1. SI1802H04803734

    SI1802H04803734 New Member

    I have been using Razer Synapse 3 for some time now on my pc, but one day when I tried to open the application the entire software just gives up on me, so I uninstalled it and tried to reinstall it. But when I did an Error sign showed up with error code 528040 (RazerSynapseDepenenciesSetup). I have shut down my computer and tried multiple times but I still couldn't fix the issue. Does anyone know what is going on?
     
  2. G_Leland

    G_Leland Member

    Ssory for question,
    but i should ask u.
    Do you have licensed OS?
    Not ckraked, not downloaded etc?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >