Razer Synapse 3 not working on Windows 11

Discussion in 'Razer Support' started by iMSh4d0w, Oct 16, 2021.

Thread Status:
Not open for further replies.
  1. iMSh4d0w

    iMSh4d0w New Member

    Hello,

    since some people can run Synapse 3 on Windows 11, I want to ask how did you get it working or do you know anything that i can do? I reinstalled Synapse 3 and even Cortex multiple times, i deleted all Razer files and my Driver for the Deathadder Elite V2 Pro aswell but it's still telling me that it Failed to start.

    Windows specifications:
    Version: 21H2
    OS Build: 22000.194
     
  2. iMSh4d0w

    iMSh4d0w New Member

    Nevermind, I found a solution.

    I deleted all files and drivers again and only used my keyboard to install synapse and now it works.
     
  3. edup_2004

    edup_2004 New Member

    Do all of your devices work on Synapse?
    Because I did the same as you did and only my keyboard works properly.
    Synapse won't detect my mouse unless connected by cable and some of the device's mapping won't work at all.
    They all respond only before synapse loads when I restart my PC.
     
  4. iMSh4d0w

    iMSh4d0w New Member

    I'm only using a Razer mouse. I just can tell that deleting all files from Razer and deleting the device drivers worked for me.
     
  5. Razer.GuitarScar

    Razer.GuitarScar Active Member

    That's good to hear. Never hesitate to send me a PM if you have other concerns or questions.
    Which Razer mouse do you own? Do you mind sending me the serial number via PM? That way, I can take a closer look at the issue.



    I'll lock this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >