Razer Synapse 3 not working

Discussion in 'Razer Support' started by Josepic, Apr 6, 2021.

Thread Status:
Not open for further replies.
  1. Josepic

    Josepic New Member

    I recently just bought a Nanoleaf product with the intention to link it to my Razer devices. Initially, it worked fine but soon after, I'm not sure if it is directly related, but my Razer Synapse 3 began to stop working. It would not longer open properly and an error message would appear, prompting me to restart the program which did nothing. I tried reinstalling through Razer Central which also seemed to do nothing. I read a few threads and decided to delete all Razer software from my computer which I managed to do and reinstall everything after that. This too did not work and now Synapse seems to work even less, asking for admin permissions every time I try to open it, and most of the time not actually open at all. On the rare occasion, it does open, it doesn't work at all and can't connect to any of my Razer products. I really like Razer when the software decides to work so I really want to fix this issue
    Last edited: Apr 6, 2021
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Thanks for starting this thread. Were there any Windows updates done to your system before the issue happen? Let's isolate the problem by following the steps provided by this link. Should the issue persists, please send me the following:

    a. Screenshot of System Information (Hit Windows+R to open the Run box. Type “msinfo32” into the “Open” field, and then hit Enter.)
    b. Screenshot of Windows version (Hit Windows + R. Open the Run box with then type winver)
    c. Screenshot of Synapse version (Click the gear/cog icon at the top right. For Synapse 3.0, click “About”).
    d. Synapse 3.0 logs.

    Save the compressed files via Google Drive or any online drive account, then paste the link in your PM. Let's continue from there. I'll be locking this thread now.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >