Razer Synapse 3 refuses to run (Jan 2021)

Discussion in 'General Discussion' started by Brobotbot, Jan 3, 2021.

Thread Status:
Not open for further replies.
  1. Brobotbot

    Brobotbot New Member

    Ever since Dec 2020, My synapse hasn't been running. I read extensively on different voodoo magic that people attempt in an effort to get Synapse to run. Start --> apps and features --> razer synapse modify --> repair and restart. I did the same thing but had the razer accessories unplugged. I unplugged accessories, deleted razer accessory drivers on device manager, restarted and plugged in accessories to have the newest drivers automatically download. Literally nothing works. I have seen others with this issues as of late.

    Please Razer give me some guidance or other users please let me know if there are alternatives to Synapse 3 for keybinding razer products, creating macros and changing razer RGB lighting.

    - Happy 2021 everyone
     
  2. Hi,

    I have the same problem since a windows 10 update.

    I solved the issue by uninstalling last windows 10 update feature.

    Hope it will be solved by razer.

    Regards,

    Fred
     
  3. Brobotbot

    Brobotbot New Member

    Ahh thanks for the reply fred, I was hopeful that it'd work but unfortunately it didn't. I remember Razer Synapse stopped working just before christmas so I looked at my update history and uninstalled the update on 12/21/2020. Glad it worked for you though. Would really like my RGB effect Razer!! I cant use keybinding unless through your app so plz help me get it fixed already!
     
  4. For me, the problem was the program "Riva turner"
    i have to close it and synapse 3 works perfectly.

    Hope you have the same issue.

    Regards,
     
    FiszPL likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >