Razer Synapse 3 won't work

Discussion in 'Razer Support' started by MCP5_, May 20, 2021.

Thread Status:
Not open for further replies.
  1. MCP5_

    MCP5_ New Member

    It's been at least a week since my razer synapse has stopped working. This happened to me one before and I fixed it by uninstalling/reinstalling. But this time when I go to uninstall, the service that asks you why your are uninstalling doesn't load. It infinitely loads and doesn't show up. Therefore, I can't uninstall, and I can't open synapse either. I've tried everything on their website for this and nothing has worked. I tried talking to support but it wouldn't let me. So, I'm here, please help! Desktop Screenshot 2021.05.20 - 18.53.40.36.png .
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey there! Are you using a personal computer and connected to a home network? Have you tried repairing your Razer Synapse? If you haven't, please follow the steps from this link. Ensure that your anti-virus or firewall is not blocking any Razer-related files or apps.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >