Razer Synapse Crashing when changing colours

Discussion in 'Razer Support' started by firstRustyRedvalley544, Dec 21, 2019.

Thread Status:
Not open for further replies.
  1. A few weeks ago, my Razer Synapse program for Mac OS started crashing instantly whenever I tried to change the colour of my thumb buttons and Razer logo on my Naga Chroma. I have been unable to fix this, and have tried redownloading Synapse already. Please help, as I changed the colours while messing around to something I don't like and am unable to fix it. I am able to send a screen recording of it crashing if you need. If anyone knows a solution to this problem, please answer.
    narcissubox likes this.
  2. PT.Singer

    PT.Singer Jedi Master

    Out of curiosity, what Mac OS version are you running?
  3. How do I check that ;p. Sorry, not really a tech genius. A 'boomer', if you will.

    Nevermind found it. Mac OS Mojave version 10.14.2
    Last edited by a moderator: Dec 21, 2019
  4. PT.Singer

    PT.Singer Jedi Master

    Ok, good.

    Did you recently update your version of Synapse for Mac, and did the problem happen shortly after the update?

    Next question: when you re-installed Synapse, did you completely uninstall it first? If you are unsure, you can find the uninstaller in your Utilities folder, which can be found in your Applications folder. If all you did was try to re-install over the previous installation, I would suggest completely uninstalling the software using the uninstaller, and then re-downloading and installing the software.

    This will at least get the ball rolling for Razer Support, as that is most likely the first thing that they will ask you to do.
    Last edited: Dec 21, 2019
  5. Honestly, I'm not sure when the problem occurred, it's just I noticed it around a week ago when I tried to change the colour, sorry. It could have been after an update. For the second question, I completely uninstalled Synapse before reinstalling it.
  6. PT.Singer

    PT.Singer Jedi Master

    I just tried PMing you, but the system wouldn't let me, for some reason.

    If you would like to try it, I have the installer for the previous version of Synapse for Mac - 1.86 (I have all of the Synapse for Mac installer files going back to 1.59, because you never know). PM me your e-mail address and I'll share a Dropbox link with you.

    If it fixes your issue, then your original problem might be a simple conflict between something in the current version and the OS, or even the current version and something ELSE that you might have recently installed. If you haven't installed anything else for a while, and just updated Synapse to 1.87 before the problem started, then I would suggest that you submit a bug report via Synapse, and hopefully they can get it sorted in a future version of Synapse for Mac.
    ssipster likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >