Razer Synapse doesn't recognize my mouse

Discussion in 'Razer Support' started by Art.Porto, Apr 10, 2019.

  1. Art.Porto

    Art.Porto New Member

    I have a Razer Mamba Chroma, I bought a year ago.
    It worked fine for a whole year, showed up on the Razer Synapse and I could set the DPI and colors, everything was ok until yesterday. Razer Synapse stopped recognizing my mouse, I did everything I found on other threads and didn't work.
    I already uninstalled the Synapse, deleted all the files, runned CCleaner and installed the last version, but it doesn't recognize.
     
    BenZe13 likes this.
  2. BenZe13

    BenZe13 New Member

    same here with DA chroma
     
  3. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Let's work on that. Please send me the serial number of your Razer devices through PM. Make sure to include the following: screenshot of your Razer Synapse, your current version of your operating system, and the link of this thread. Let's continue from there.
     
  4. SmashedBrotato

    SmashedBrotato New Member

    If you find a fix let me know, my DA Chroma is recognized lighting wise, but nothing DPI etc. I've also done the uninstall reinstall of Synapse/Driver, CC cleaner.
     
  5. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Hi there, @SmashedBrotato! Can you send me the serial number of your Razer DeathAdder mouse through PM? Make sure to include also the link of this thread. Let's continue from there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >