razer synapse not detecting devices

Discussion in 'Razer Support' started by Guanco123, May 24, 2018.

Thread Status:
Not open for further replies.
  1. Guanco123

    Guanco123 New Member

    hey guys, i'm well aware that there are countless forums with this similar issue but i can't seem to find a decent fix for mine.

    I'm in possession of a razer deathstalker chroma and a razer naga chroma, the issue with these devices are that if i use synapse 2.0 then My keyboard is the only thing that's getting detected but if i uninstall synapse 2.0 and download the 3.0 then my mouse is the only device that's being detected. how could i possibly fix this issue? it's kinda irritating to have this problem, i personally don't like using synapse 3.0 because it's very laggy and it makes my mouse freeze sometimes or my macro buttons respond slower (delayed).

    I have reinstalled synapse many times with pc restarts in between, i also reinstalled my mouse and keyboard drivers in device manager countless times but i have no luck at all>

    thanks in advance
     
  2. RealMysterio

    RealMysterio New Member

    Hi,
    as you can see on this page, your Razer Deathstalker Chroma isn't yet compatible with Synapse 3.0. Only your mouse, Naga Chrome was recently added to the supported devices. As far as I know, Razer is right now busy with supporting more "older" devices in 3.0.

    Synapse 2.0 should detect both of your devices. I had a similar problem with my brand new Razer Basilisk, no matter what I did, Synapse (3) wouldn't recognize it. After trying some things I found out that I plugged it into my USB 3 port, where the drivers seem to be broken. After plugging it into an USB 2.0 Port, Synapse finally "found" my mice.

    Please try it on different USB ports, 2.0 and 3. On which OS are you?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >