Razer Synapse not Installing

Discussion in 'Razer Support' started by JaydontheThing, Oct 15, 2018.

Thread Status:
Not open for further replies.
  1. JaydontheThing

    JaydontheThing New Member

    I recently bought a Razer Mamba Elite and when I plugged in the mouse it came up with the software installation. I tried installing it and it just didn't do anything and after a while it came up with installation failed. I tried literally everything; turning off and on my computer, reinstall ing the drivers and files. Yep!! I give up! Can anyone help? Oh! and also I did try synapse 2 but I know that doesn't work with the new mice and it also came up with the same thing.
     
  2. FatKidWanderer

    FatKidWanderer Well-Known Member

    Hola, @JaydontheThing! May we know what is the error message that you are getting when trying to install the mouse?
     
  3. JaydontheThing

    JaydontheThing New Member

    Ok I will tell you when I get on my computer today. I will do a screenshot

    This was after it got stuck saying 0/250 MB or whatever amount it was.
     

    Attached Files:

    Last edited by a moderator: Oct 17, 2018
  4. FatKidWanderer

    FatKidWanderer Well-Known Member

    Thanks for the screenshot. Before running the app, make sure that you temporarily disable your antivirus or firewall on your computer to make sure that installation would go through.
     
  5. JaydontheThing

    JaydontheThing New Member

    I have disabled the firewall. In fact it is always disabled cause I have an antivirus, but I would need my dad to unblock it and he is a very busy man so I think I would have to wait till the weekend.
     
  6. FatKidWanderer

    FatKidWanderer Well-Known Member

    No worries. The error could be on the network that you are connecting to as it may be blocking the connection to our server. If this is a wireless computer, you may try to isolate the issue by connecting to another wireless network.
     
  7. JaydontheThing

    JaydontheThing New Member

    Oh I used two computers with one wired and one wireless and it still didn't do anything
     
  8. JaydontheThing

    JaydontheThing New Member

    No worries. Problem sorted. It was my antivirus
     
  9. FatKidWanderer

    FatKidWanderer Well-Known Member

    Thanks for the update. Good to hear it works now. Locking now the thread.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >