Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. kevmanrazer

    kevmanrazer New Member


    thank you for this great detailed reply. I may hold off for a bit.
     
    the_novena likes this.
  2. Seegeth

    Seegeth Member

    Update 3.6.331.31613, no improvement :slightly_sad:
     
  3. NoahArk620

    NoahArk620 New Member

    Thanks man, now I don't need to test it for myself. ;)
     
  4. the_novena

    the_novena Member

    Same -- updated to 3.6.331.31613 ... issue persists.
     
  5. My new Tartarus V2 has the same issue with Synapse 3.6.331.31613
    I've collected multiple logs before sending the device back to get a refund. Maybe the logs help the devs.
     
  6. Seegeth

    Seegeth Member

    @Razer.Speedcr0ss Has the technician succeeded in replicating the "problem"?
     
    Koshirun likes this.
  7. WhiteFox935

    WhiteFox935 New Member

    Hey guys,

    same problem here... I've got the third Tartarus V2 now and still same problems. Tried the Pro version, same problem... Tried different USB ports, USB hub with power supply, reinstalled the software (with deleting all file and config stuff in Windows) and still: same error.

    The support asked me several times to close all Synapse Apps and to test ingame if the error still occures - but I've never got an answer how to test the stick without the possibility of binding a profile to the device without the necessery software...

    Even if the Razer support is fast and friendly but: the problem still persists...
    Wondering if there will EVER be a solution for it, waintig for six month now...

    @Razer Support, my ticket numbers: 210215-000039, 210223-002818, 210323-000814 and the collection of tickets is growing.... In the past, for me Razer hardware and software was a synonym for quality!

    Cheers
     
    Last edited: Mar 22, 2021
    Koshirun likes this.
  8. Zilz2

    Zilz2 New Member

    Same here, problem persists even after update.
     
  9. Daisame

    Daisame New Member

    Razer support has given up on solving this issue. After they RMA'ed my Tartarus pro, the issue persisted. They made me open a new case. For some reason the existing case "confused" them. So I opened a new case, referenced the old case. And the first thing the new case wanted, was to re-run ALL the previous troubleshooting and information gathering steps again. Which there are A LOT.

    When I said I was not going to run them again, and to just look at all the previous data I sent them, they responded with this:

    "Good day!


    We would like to inform you that we will be closing the case and you may contact Razer support from this link for further assistance: https://support.razer.com


    Thank you so much for having business with Razer and have a wonderful day!



    Sincerely,


    Ronnie
    Razer Customer Service"

    It appears Razer has no interest in solving this problem. I offered to work with them to run any debugging software or mode of Synapse so they could hopefully identify the issue and correct it. That did not seem to appeal to them at all. I would highly recommend returning any Tartarus products or anyting that may rely on Synapse 3's key mapping abilities. Or... buy some third party app, if you truly must use a Razer product.
     
  10. Zilz2

    Zilz2 New Member

    It's beyond obvious this is a software issue and not a hardware issue and they know this, those RMA's and 'troubleshooting' methods are just to get us discouraged to take any more steps. Also i don't believe this "Razer.Speedcross' guy that has been posting here and claims he has been reporting our problems to his so called 'team'. He is just trying to keep us occupied by making us believe they are working on the problem, when they are clearly not.

    To the ones reading this thread and are considering to purchase a Razer Tartarus (v2, Pro, or any), be smart and don't waste your money!
     
  11. Seegeth

    Seegeth Member

    This is getting very annoying now.
    Recently, the problem was once an hour, now it happens several times an hour.

    I already wrote about it some time ago, but can't the dev team really sacrifice one person to write some driver to be able to use Synapse 2 with basic functions like binding keys.

    It's not a perfect solution, but it's a good way to wait and see if it's a Synapse 3 problem.

    It would also be nice if there was more information about what is being done.
     
  12. Zilz2 likes this.
  13. CptCraptacular

    CptCraptacular New Member

    man am i happy that i just paid the £5 to use rewasd. just thought i would come in here and see if they have fixed their cruddy bloat/spyware yet. ofc not because there is money to be made and they have already got all off ours, so why spend r n d time on this when you can release more products. which will will also still have the same problem but hay we are "for the gamer" glad i have seen through that lie now, not so glad it cost £130
     
    Zilz2 likes this.
  14. WhiteFox935

    WhiteFox935 New Member

    Is rewasd working with Tartarus?

    I am using Synapse 3 to control all my LEDs - Razer, ASUS and DIYHUE... I think I'll give OpenRGB another chance, it did not support all my devices last year. Someone told me, Aquasuite made by Aquacomputer will control "all" LED devices (MSI, ASUS, Razer...) in the future.

    For me, it was the last Razer product I've bought... Possible that I'll sell all that Razer trash and buy some working stuff... I think Razer has forgotten, that many disappointed gamers know many other gamers how would like to buy new gear - and I will NOT recommend them to buy any Razer product because it only looks nice but don't work. Btw, my newest support ticket is three days old and I did not get an answer yet. Maybe Razer support has closed because of wealth :)

    About 15 years gaming with Razer will end like that...
     
  15. Seegeth

    Seegeth Member

    Today there was another update, this time probably Tartarus itself, because the Synapse 3 version is the same, but I don't know how to check the firmware versions.
    I will test in the evening in games to see if anything has changed.

    @WhiteFox935 rewsad works but not fully, you cant bind wheel and control rgb
     
    Last edited: Mar 25, 2021
  16. NoahArk620

    NoahArk620 New Member

    It is probably the same version being redistributed at a later date. Mine showed up as being released on 24th March.
     
  17. Seegeth

    Seegeth Member

    I had an Synapse 3 update on March 21, and this time Razer Updater show message that my device will not work during the update, I do not know if it is a Tartarus update or an additional Synapse module, but I received some update today.
     
  18. WhiteFox935

    WhiteFox935 New Member

    Hmmm, ok, thanks. But a useless wheel is better then a useless D-Pad :) I'll try it, tanks.
     
  19. WhiteFox935

    WhiteFox935 New Member

    No update today. But I'm in Germany and I think that updates for German systems will be online some days later.
     
  20. Seegeth

    Seegeth Member

    I am from Poland.
     
    WhiteFox935 likes this.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >