Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. CptCraptacular

    CptCraptacular New Member

    i think someone linked a video on youtube on here at some point just use that one for proof of "hardware problems" because if they can notice multiple people use the same video then maybe there is some hope they can fix the problem
     
  2. Daisame

    Daisame New Member

    That is 'hopefully' what their Log File Collector app does. You start this debugging program... play a game and duplucate your isssue, then stop the program to collect the logs. I did that and sent it in. I can only hope it has some sort of valuable data in those logs that can point to a problem.
     
  3. Daisame

    Daisame New Member

    I did that actually, Support did not 'want' a copy of someeone else's video. Unless they just want me to PROVE I am having the problem, there is literally no value to record a seperate video showing the exact same symptom. It should be very clear what the symptoms are at this point. Now we just need devs to look over debugging logs to find what is causing it and fix it.
     
  4. Daisame

    Daisame New Member

    Razer support wants a video again and run through the same steps as before with using a different cloud account. I am truly amazed at how Razer continues the same old script over and over again, seemingly without realizing it makes them look extremely foolish. I regret the day I bought the Tartarus Pro. I think I need to just give up on Razer ever taking this issue seriously and use a third party's key-remapping software and just never buy from Razer again. They will not get the picture until they stop selling product. And it seems like they would be clueless as to why their products don't sell any longer.
     
  5. KingPrawnJafrezi

    KingPrawnJafrezi New Member

    I have this issue as well with not only the D-Pad any longer. It seems the whole keypad now gets stuck at times. Happens a few times a gaming session on Warzone now. Really annoying when I aim down sight at it stays aimed down site when I'm walking in the open. Or when I have to do a full 360 click on the d-pad to unstick. Used to happen every once in a while and now seems to happens more and more often. Please fix this Razer. I love the Tartarus but this is really becoming annoying. I don't want to move my character with WASD. I want to move my damn character with my THUMB which is why I got the Tarturus.
     
  6. Daisame

    Daisame New Member

    I was finally able to submit a video of the issue. You can all see it here :

    I sent this to Razer support and they claim it is a hardware issue... again. :slightly_sad:

    I then asked them to please send as many units as it would take to rule this out as a hardare issue (being this is already the second unit I have tried) and I would try them one at a time until they all failed, or one worked. I think one of the other posts is right. They just try to wear down the resolve of their customers until we just forget about it or let it go.

    Why is the community aparently working harder to solve this problem than Razer? The Tartarus Pro would be incredible if not for the POS Synapse software.
     
    KingPrawnJafrezi likes this.
  7. dfscott

    dfscott New Member

    To clarify the workaround: does reWASD let you map the thumbpad to keystrokes as well (e.g., wasd for movement) or do you lose that functionality as well? I could live without the scroll wheel but moving with the thumbpad is the main reason I use keypads.
     
  8. NoahArk620

    NoahArk620 New Member

    Yes. Just remap the arrow keys, and it should take an effect. Give the trial a go before you make the decision to purchase the software.

    Also, sorry for the late reply. There is quite literally no news on my end. The troubleshooting steps i mentioned (no brightness, default green static lighting, default keymapping) does not work on my end either, so we can still safely assume it is not related with Chroma SDK.
     
  9. dfscott

    dfscott New Member

    No worries but thanks for the update. I've recently started using an Azeron but the jury is still out on whether it's going to be a workable solution (steep learning curve). If it doesn't work out, at least I'll have this as a fallback.
     
  10. Cr33345

    Cr33345 New Member

    I tried all these things also and finally after getting no help found a for sure fix for almost everyone. I just posted it, titled. How I fixed Tartarus V2 sticking keys.
     
  11. Daisame

    Daisame New Member

    Razer support asked me to send my PC motherboard, CPU, and GPU Make and Model as well as the RAM. I told them I would but asked if they wanted it for the three different machines that experienced the issue. It surely is not tied to one hardware setup. It happened on 100% of the machines I have used. Although I have not tried it on my new laptop yet, so I could give them 4 different machine specs.
     
    the_novena and Cr33345 like this.
  12. Cr33345

    Cr33345 New Member

    Razer has let us down, they must know by now it is not a hardware glitch and yet straight faced they lie to us causing us to suffer hours of attempted fixes when it is all them. Angered that I died so many times due to the V2 and losing street cred and team mates that I have bought a new game pad. It is saving me time, memory, and grief. The Red Dragon DITI is working great for me right out of the box, with more buttons and cost less, does not have to update ever thus far, and is more comfortable for me. Good luck dealing with them.
     
  13. Daisame

    Daisame New Member

    I have an old Logitech G13 that I can use, but prefer the keys and layout of the Tartarus. I loved the old Belkin Nostromo that this is based on. I just wish Razer's Synapse software was not such crap. I have been dabating paying the $20 for the reWASD software. It is an extra expense and pretty clunky, but it at least works. Which is more than can be said for Razer's software. I just want to hold Razer accountable for producing a working product, but it is exhausting going through the steps over and over again with each new support person. They need to get a Project Manager to lead this effort, collect all the reports, get a tiger team on their dev team and identify and solve this like the real problem that it is.
     
    the_novena and Cr33345 like this.
  14. Daisame

    Daisame New Member



    My Tweet to Razer and Razer Support
     
  15. KidGixxer

    KidGixxer New Member

    I am definitely debating changing out the dpad for the Arduino/Thumbstick mod. I doubt this will be getting fixed in any of the current iterations of the Tartarus.
     
  16. Cr33345

    Cr33345 New Member

    I do not see any signs of Razor actually caring about this problem. But I am also learning that the Tech world is not one to be praised for their communication skills. Good luck getting a fix.
     
  17. Cr33345

    Cr33345 New Member

    So after all these efforts to help them help you did you get any results????
     
  18. the_novena

    the_novena Member

    Sooo many of us have tried to provide everything they've asked for, numerous times ... followed all kinds of trouble shooting steps; collected and submitted Synapse log files; sent units back for further tech inspection, etc, etc, etc ... soooo many efforts to "help them help us" ... and still no satisfactory results.

    When it became clear to me that Razer has given up on this issue, I was within inches of giving up on them.

    THEN, a whole new issue: my Naga Pro developed issues of the left mouse button generating a double-click when only a single click was pressed. Sent it back on RMA but bought a Logitech G600 to use while I waited for a new Naga Trinity replacement. Razer's replacement arrived and I'm saving it (brand new in box) in case I ever have problems with the new Logitech G600. ... The mouse issue is off-topic from the Tartarus issue this thread is based upon, so I won't go off on a tangent, but suffice to say, this was my breaking point.

    I paid for reWASD, and have enjoyed flawless gaming ever since. If anyone is on the fence about this third party software, honestly just choke up the small cost and do it -- it will save you a whooooole lot of grief!
     
  19. Rodorn

    Rodorn New Member


    Hi mate, I started having this issue just now, sent it to RMA as I suspect hardware fault as well, I will look into reWASD when it comes back. A quick question tho. Were you able to somehow disable it the keypad in razer synapse so you still had keyboard/mouse in synapse but keypad in reWASD? Or at least make lightning work without synapse?

    And also what version did you buy? The basic 6 USD one or premium?
     
  20. the_novena

    the_novena Member

    No, @Rodorn ... Over the last few months on this thread (somewhere back around page 12-15), a few of us have tried disabling the HID (Human Interface Device) for the Tartarus alone, to see if that would make a difference, but no ... it ultimately didn't work. The problem continued to return.

    As for running both Synapse 3 and reWASD simultaneously, no ... it isn't really possible/advisable; you will end up with conflicts between the two.

    For me, I am using reWASD only for the Tartarus.

    I don't need to use reWASD for my mouse because my Razer Naga Trinity and my Logitech G600 mouse both have onboard memory. (use Synapse 3 or Logitech G-Hub initially to set up all your mouse button key-bindings, then they will be stored to onboard memory. So from then on, they will work without needing their native software running in the background).

    I don't need to use reWASD for my Blackwidow keyboard, because I never made any customized key-bindings on my keyboard; I've always just used it at the factory defaults.

    It is worth noting however that reWASD is capable of managing a few/several devices at once. This includes most gaming mice, keyboards, and controllers, if/when you ever want it to. I personally only need it to manage my Tartarus, ... but it's nice to know that it can manage more if I ever need it to.

    As for the RGB lighting, the bad news is: no -- you won't be able to customize that lighting in reWASD like you can in Synapse. This sacrifice is a bummer. Now that I've divorced myself from Synapse 3, my Razer devices just cycle through the different colours at a slow/gradual cycle, which I think is the factory default. Even slightly more sad: the cycle on all three devices are not even synchronized, lol. So, my desktop doesn't LOOK as pretty as I would like it to ... but at least it finally WORKS again, which is what's most important.

    I ended up going with the $20 version for two reasons:
    (1) My frame of mind was just that frustrated. I was just, like, "take all my money; solve all my problems!" lol!
    (2) I need a couple buttons to do macros; not just single keybinds. Macros are part of the premium package.
    I don't regret a penny of it, but if all you need are single keybinds (which is fine for many/most users) then you'd probably be able to get away with just the $6 version.

    My best advice here would be to just try the free trial. They will let you trial the basic version for two weeks free of charge, AND ... they will allow you to individually add in the premium features too, so that you can test drive them for three days free of charge.

    Hope this helps!
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >