Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. the_novena

    the_novena Member

    @KAWAiiSONG : Glad you got no errors; me too! Let us know what happens when you move on to Step #4 - #6.

    @Seegeth : I began testing this last night, but ugh, I made a stupid mistake:

    1. Ran DISM tool and System File Checker tools again (no errors).
    2. Restarted computer
    3. Start testing (problem recurred in just under three hours)
    4. Created another local Windows user account (no password; "No" to all privacy settings)
    5. Signed into new local Windows account (but forgot to LOG OUT of my main admin Windows account!!)
    6. Started Synapse 3; logged into my Razer account; began testing (problem recurred in just over 3hrs)

    So although I was signed in as "TestUser" on the new local Windows user account I had created, I was ALSO still logged in under my usual admin account. Hours of testing, kind of down the drain.

    (Also: It didn't take me long to realize (much to my dismay) that all of my game's addons are stored in the Windows username folders. So, with a new Windows user account, I had nooooo addons. And I'm a very heavy addons user, so I missed them terribly, lol. It was kind of brutal playing without them.)

    So now, I'm back to the drawing board and will begin testing again. I hope to report more later tonight or tomorrow!
  2. CptCraptacular

    CptCraptacular New Member

    indeed but i would be willing to not have rgb etc while they fix they drivers, as it stands now i would have to do all these bodge style fixes. all because they skimped on a chip, what is almost industry standard in gaming peripherals at this point. i know quite a few off their mice have it so why the left it out on a real high end product baffles me
    the_novena likes this.
  3. roger32025

    roger32025 New Member

    Hey guys, I'm Draxxille by the way. I just wanted to drop in and say it's awesome to see that the community and Razer is getting this worked out. If there is anything I can do to help let me know.
    jhnclvr likes this.
  4. the_novena

    the_novena Member

    Hey, man! Thanks for chiming in on the thread, and thank you especially for bringing reWASD to our attention on your video segment. Since you're kind of in the same boat as I am (owning other Razer peripherals and therefore reluctant to quit the Synapse software entirely), I wonder if you might also be willing to give the proposed troubleshooting a try? (creating a different local Windows user account). The more testing and troubleshooting, the merrier! ... Hope you're on the mend, and doing well! :cool_:
  5. roger32025

    roger32025 New Member

    Of course, it's just amazing to see that we are pulling a community together to get this fixed. I know a larger sample size is important, trust me, lol. I'll do all I can to help out and post my results here. I'll give that a go and see what happens. I'm doing good, I had my one surgery if you saw that video and I got the next one on the 21st. It sucks cause I'm finally getting to move around.
    the_novena likes this.
  6. Seegeth

    Seegeth Member

    @roger32025 Hi, thanks for drawing our attention to reWASD, it's a good alternative. The only thing that doesn't work is the scroll wheel binding.

    For me, System File Checker found corrupted files and repaired them. (the problem was still there)
    Did the option with a local account help someone else or just me?

    Today I will try to play 3-4 hours and see how it will be.

    Operating System: Windows 10 Pro (20H2)
    Razer Software: Synapse 3 (version 3.5.1215.121019)
    Other devices: Razer BlackWidow Tournament, Logitech G502, Astro A50
    i7 7700K
    16 GB DDR4
    RTX 2080
    Lastest drivers and Windows update.

    Razer BlackWidow Tournament, uses Synapse 2, but I don't have it installed.
    Last edited: Jan 15, 2021
  7. NoahArk620

    NoahArk620 New Member


    Thanks a lot for the suggested steps! I will try this on my secondary device where I still have synapse 3.0 installed.

    I personally rely heavily on Microsoft account syncing for work between my primary and secondary account, so I am wondering if you had tested reverting back to Microsoft account afterwards to see if the issue continues to show up?


    Oh wow, I was expecting my OneDrive to not sync up after converting to Local, testing this would be a breeze!

    Just quick question to everyone, this month's Synapse update hasn't been pushed out yet, has it? I am still on 3.5.1215.121019.

    @roger32025 Nice to see you again, Draxille! It is so nice to see you roaming in this forum too!
    Last edited: Jan 15, 2021
  8. Seegeth

    Seegeth Member

    Good idea.
    Today i will test with local account - 3 - 4 hours, tomorrow i convert local to microsoft account, and test it.
    NoahArk620 likes this.
  9. NoahArk620

    NoahArk620 New Member

    Ok, reporting in just after a few hours of testing. I followed through @Seegeth steps, but I omitted the part involving making a new test local account.

    I had already done sfc /scannow, converted my main admin account to local account, restarted pc, and log back into Synapse 3.0 through my own account. The problem unfortunately occurred sometime after 2 hours of testing.

    Maybe i'll try making a new local account next time, but for now, my current conclusion is that it doesn't work.

    (I remember doing something else prior, and had no issues for 2 weeks, but it comes back with a vengeance right after, but that was months ago already.)
  10. KAWAiiSONG

    KAWAiiSONG New Member

    So, I made a second Windows account after spending 2 hours in the game no problem! I realized that the second account turns out to be empty! it is not clogged with different software and processes ! perhaps there is something with which there is a conflict with Synapse 3 ! after checking both accounts, I noticed that a lot of software is not in the installed programs-Opera, Offece , TeamSpeak, as well as many other software is not running. there is an option to check without creating a second account ! disable all processes except system processes. I think we all have some software that unites us . check if this is the case!
  11. KAWAiiSONG

    KAWAiiSONG New Member

    1.Disable any extraneous Windows services that are installed by third-party software that is not part of the OS.
    2. Press the Windows key + R key combination. A menu will appear to enter https://i.imgur.com/sKSZ6YB.png
    3.Write msconfig and click ok. The system setup application will open.
    4. Go to the Startup tab and disable all applications from the list.
    5.Next, go to the Services tab and check the box next to "Do not show Microsoft services", then click Disable all.
    6. After these actions, click "ok", you will be prompted to restart your PC. Please reload it. After restarting, try starting the game without launching any programs.
    Razer.Speedcr0ss likes this.
  12. Seegeth

    Seegeth Member

    I don't think so. After using New Local Account, i converted my administrator (microsoft account) to local and it works. I have all my processes active.
  13. KAWAiiSONG

    KAWAiiSONG New Member

    This has nothing to do with it! I originally and always had a Local administrator account! that it never helped me!
  14. Seegeth

    Seegeth Member

    Broke again. Within 2.5 h, stuck once.
  15. the_novena

    the_novena Member

    Oh, damn -- so frustrating! Just to be clear, this failure was under which of the following circumstances?

    (a) The 7th to 10th day after you converted your main user admin account to a local account?​

    ... or ...​

    (b) Right after you had just tried converting your main user admin account back to an online account?​
  16. Seegeth

    Seegeth Member

    (a) The 7th to 10th day after you converted your main user admin account to a local account
  17. the_novena

    the_novena Member

    Okay, so to summarize ...

    Razer tech troubleshooting queries and steps:

    Unsuccessful fixes:

    • Switching USB ports to a different port on my PC (front port to rear port).
    • Running the 'repair' tool in Windows to repair the installation of Synapse 3.
    • Replacing the device with a new replacement device (RMA).
    • Excluding Razer modules (Chroma Studio; Macro) from a clean re-install.
    • Creating and using a new Windows user local account, while simultaneously remaining logged into your primary admin account.

    Various successful immediate work-arounds:
    • Pressing the affected button again ceases the immediate current occurrence of the looping repeated function. Note however that the issue continues to occur. The frequency varies per user.
    • Logging out and exiting the Synapse 3 software entirely.*
    • Connecting the device to a different PC without Synapse 3 software installed.*
    • Using third party key binding software such as reWASD instead of Synapse 3.*
    * Note: This will result in some functional

    Various successful short-term fixes:
    * Note: Issue typically recurs between 3 - 14 days.
    • Clean uninstall/re-install of Synapse 3 software. Standard uninstall/reinstall may be sufficient, but clean is better.
    • Logging into a different Synapse 3 user account (razertest; razerperipheralstest; etc.).
    • Converting your primary Windows user account to a local account (if it's not already local).
    These each seem to be
    Last edited: Jan 16, 2021
    Razer.Speedcr0ss and NoahArk620 like this.
  18. NoahArk620

    NoahArk620 New Member

    @the_novena Incredible summary you made there!

    There are many more unsuccessful fixes outlined by many users in the pits of comments on the reddit post below, including forcing Tartarus v2/Pro to not be recognized by Synapse 3.0 while the program is running. (But it seems the driver is still running) I didn’t open this reddit post, so it is quite rough.


    @KAWAiiSONG The 3rd device i tested with, which is my work’s PC are mostly barebones and was running off a local account (not local admin account). Issue is still there.

    I really need to emphasize that testing to replicate the issue takes time, weeks even. My longest time without issue was 2 weeks (Possibly with human error not noticing), my shortest time was 2 minutes (lol), and on average it is usually 2 hours.
    the_novena likes this.
  19. the_novena

    the_novena Member

    Alright, so I’ve been thinking and wondering about some questions/hypotheses. Would the following theories be helpful to test, or not?

    Theory #1
    In my previous post, I mentioned short term fixes, which ended up being briefly effective for a range of 3 – 14 days. Of those listed, most of them could be done individually (independent of the other short term fixes). The one I am uncertain of is the System File Checker. Therefore, I am wondering …

    True or False:

    Running the System File Checker alone – provided it detects and repairs errors! – is effective at providing a short term fix for a few days to a couple weeks.

    Running the System File Checker alone – when it detects no errors – is not effective.​

    @Razer.SpeedCr0ss ... would determining this be helpful at all to the Razer tech team, in isolating the issue? Or does it not really make enough difference to be worth testing? Testing would need to be done by someone who would be more possibly likely to have errors detected in their system files (therefore, someone who has not recently run the system file checker, and had their errors repaired).

    Theory #2
    @Seegeth performed extensive testing (7-10 days) on converting the primary admin Windows user account to a local account. So did @NoahArk620 I think? Although it seemed promising, this only ended up being effective as a short term fix. Limited testing was also performed on creating a brand new subordinate local Windows user account. For a couple/few days, Seegeth said this was testing well. Is it worth it to explore this further?

    (a) Have someone test this theory for a couple weeks? It’s important to be sure that this is the ONLY Windows user who is logged in, during testing. Don't make the same mistake I did and be logged into both, at the same time, lol! :rolleyes:

    (b) If it tests well for a couple weeks, assign admin status to this new account and test further.​

    Besides asking if this would be worth it, we should also consider: is it fair to ask someone to go to this extent? On the one hand, setting up a new local is quick, easy, and clean – and it only really needs to be used when you’re gaming/testing. On the other hand, it is still kind of onerous – especially for users who would need to download and configure voice chat platforms and addon managers, etc, for their gaming purposes.

    So, @Razer.SpeedCr0ss ...
    • Would testing this provide enough value to the Razer tech team to be worth it?
    And fellow troubleshooters ...
    • Is there anyone who might be willing and able to undertake this testing?

    Theory #3
    It is entirely possible (maybe even probable!) that the issue is caused by a software conflict – some application that perhaps we all have in common, as @KAWAiiSONG suggested. If so, determining what it is could be like finding a needle in a haystack. KAWAiiSONG provided some advice, and while that advice is certainly valid and very thorough, it seems a bit extreme. It reminds me of testing for food allergies: strip your diet down to basically nothing, and then gradually add one new type of food per week, until you’re finally able to determine which food is causing your allergic reaction. This is certainly effective at tracing the origin, … but is there an easier way?

    Would it be helpful to post screenshots of our Task Manager (CTRL + ALT + DEL), showing which applications and/or background processes we have running? Or a screenshot listing everything that launches on startup? Or a screenshot of the extensive list of items under the Details and/or Services tab? …. Or should we simply start by announcing names of all the programs/applications we ourselves have running at any given time, which we feel might be likely to be popular among other gamers? @Razer.SpeedCr0ss , is this something you could find out and advise us on? What would be the quickest and easiest way to begin narrowing down software commonalities among our community here, which might be causing a conflict?

    Please contribute your thoughts, ideas, opinions, feedback ... and feel free to come forward with your own theories, too! There are no bad ideas. Remember: Razer prides itself on being "For Gamers, By Gamers", right? Well -- we are the gamers, so we're definitely part of the team.
    This would be an exceptionally good time for @Razer.SpeedCr0ss to offer us all free branded merch, as a courtesy/thank-you gesture for all of our patience and testing, haha! :big_grin_:
  20. Seegeth

    Seegeth Member

    For me System File Checker did not help at all, found corrupted files and fixed them, but the problem continued. The only thing that helped (temporarily) was creating a new local account and playing on it. Or converting a microsoft account to a local account.

    This is a bit strange as to why some solutions only work for a while. Nothing on my computer had changed in the meantime.
    the_novena likes this.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >