Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. NoahArk620

    NoahArk620 New Member

    I can chime in,

    I had performed System File Checker prior to converting my main admin account on my secondary device (which i use for testing nowadays) into a local admin account. While SFC has detected an error on my secondary device (log stated that it fixed a file related to Microsoft NET 4.5 distribute), and promptly fixed it, the Tartarus Pro issue stil crops up after 2 hours of testing.

    In terms of softwares on my side, I can only think of ‘Discord’, ‘Nvidia Geforce Experience’, ‘Microsoft Office 2016’, ‘Microsoft OneDrive’, ‘Google Drive’, ‘Apple iCloud’, ‘Steam’ and ‘Google Chrome’ being the only softwares that are the same between my primary and secondary device, and are running on the background. Work PC (Tertiary drvice) only had Google Chrome.

    Like @Seegeth, my systems has practically went unchanged for the past year except for updates on Windows, and Synapse.
     
    the_novena likes this.
  2. CptCraptacular

    CptCraptacular New Member

    the main problem is it may be good for a few days then it can break again meaning finding a fix is such a bitch. I'm trying a fix at the moment and had no issues yesterday, but that can change in 5 minutes if i still don't get any problems for another 2 days. Will post what i have tried though, it is probably just luck for me at the moment and it will of course come back later
     
    the_novena and NoahArk620 like this.
  3. the_novena

    the_novena Member

    Ahhh, yes, that's right -- you mentioned that before, and I forgot (sorry!)


    Okay, so two users for whom System File Checker alone was ineffective. Based on this, I'm going to edit that out of the list of short term fixes on my summary post. Thanks!

    Also, that was the only error that my run at the System File Checker found too: related to the Microsoft .NET Framework, although mine is version 4.8.


    We all seem to be unanimous on the fact that some solutions seem to work over a short term range, but then the issue recurs again a while later. I don't understand it, but I feel like it must be relevant, right?! ... like something gradual or cumulative is building up over time, in sort of the same way that too many cookies can bog down your internet performance ... @Razer.SpeedCr0ss, is the tech team able to validate this theory, and/or provide feedback on this?


    Keep us posted on whatever it is you're testing, @CptCraptacular ... fingers crossed it's sustainable, and looking forward to you sharing your method.


    In terms of software, here's what we've got so far:

    Razer Forum Software Table.JPG
     
    Last edited: Jan 16, 2021
  4. KAWAiiSONG

    KAWAiiSONG New Member

  5. KAWAiiSONG

    KAWAiiSONG New Member

    I can't write messages ! at least in English.
     
  6. Seegeth

    Seegeth Member

    Windows Defender
    Norton Security
    Discord
    Opera
    Samsung Magican
    Logitech G Hub
    Nvidia Geforce Experience
    VNC Server
    Spotify
    MS Office
    MS One Drive
     
  7. CptCraptacular

    CptCraptacular New Member

    im still having no problems but there is no way that the fix i am using is going to work i just mean it can't be that simple. think i just have had good luck and will probably have the bug happen again later :slightly_sad: but anyway

    device manager/find the hid complaint consumer device with razer tartrus in it and disable it and leave all the other tartrus things on

    https://cdn.discordapp.com/attachments/587332804627529738/800397261837172756/unknown.png

    and no it decided it would do it today why is it so random arg ¬¬
     
    Last edited: Jan 17, 2021
  8. Seegeth

    Seegeth Member

    I haven't tested it yet, but I think it might be a better lead. It is easier for me to believe that all this is the fault of some driver than e.g. windows account.
     
    Razer.Speedcr0ss likes this.
  9. KAWAiiSONG

    KAWAiiSONG New Member

    Hello again! here is another interesting information, my friend has a logitech g600 , and it also sticks ! how do you like this?
     
  10. i have the same problem with razer tartarus pro sticky keys every 20-40 min that happen for sure unplayable any game like that ... im user keypad like 12-13 years belkin nostromo n52te / razer nostromo /razer orbweaver and never happen that problem for all that years with a lot hours gameplay at all this but with this razer tartarus pro that happen from the 1st day ... im back to razer orbweaver until razer fix that rly...
     
  11. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! I appreciate all the help. I suggested performing the SFC scan and creating a local Windows user account so it can help us isolate the issue. And yes, I agree that these steps are tedious. Keep in mind that this is not an official fix. By the way, the team is watching this thread and they're monitoring everyone's post. I appreciate the collation of data, video tutorial, and for everyone who tried the steps too. It's surprising that the issue is happening to another gaming keypad brand too. Our aim is to determine the cause of this and create a fix. I'll update this thread again once I got a follow-up from the team.
     
    NoahArk620 likes this.
  12. jhnclvr

    jhnclvr New Member

    I have the same problem with my Tartarus v2.

    The dpad acts like it's still being pressed in a direction after it is no longer pressed. Happens infrequently but enough to be unusable.

    For me, this is normal for Razer software. The hardware and design is great but the actual workings of the device is buggy and unusable. I've also had breaking software issues with 3 different Razer controllers on PC (Wildcat, Wolverine Ultimate, and V2).

    IMO Razer has great designs and hardware, but the software is terrible, and the issues are not limited to the Tartarus.
     
  13. the_novena

    the_novena Member

    Aww, man -- such a drag that this wasn't as sustainable as hoped. Do you feel like it lasted long enough to qualify as a short term fix (like, 3 - 14 days)? Or no -- was it still a bit short of that?
     
  14. the_novena

    the_novena Member

    Interesting?! The Logitech G600 mouse is very similar to Razer's Naga I think, isn't it?
     
  15. the_novena

    the_novena Member

    This is another voice added to the growing list of fans of the legacy devices. Myself and @KAWAiiSONG both had/have the Orbweaver Chroma, and they also worked beautifully. I've read about many other users saying the same thing. There has to be something relevant Razer can extract from this. Perhaps the solution to this issue lies somewhere in the differences between the drivers and/or software for these legacy devices (which ran on Synapse 2), and the newer ones (Synapse 3).
     
  16. KAWAiiSONG

    KAWAiiSONG New Member

    yes
     
  17. the_novena

    the_novena Member

    This pretty much sums it up fairly accurately. And true: it's not just the Tartarus's (Tartarii? lol). I've had it happen to my Black Widow Elite keyboard (once or twice). @KAWAiiSONG encounters it continuously on his Naga Pro mouse. And there have been two or three occasions where I think it may have happened to my own Naga mouse as well.

    There is indeed something terrible going on with the software, but I also recognize that Razer is aspiring to greatness (and has indeed achieved greatness in so many other ways, with their designs and hardware, as pointed out!). The one thing we all have in common is that we all just want this to work as intended. I'm determined to try to contribute to that effort, and I genuinely appreciate everyone who is participating on this thread, towards that same effort!
     
    Razer.Speedcr0ss likes this.
  18. the_novena

    the_novena Member

  19. Seegeth

    Seegeth Member

    Orbweaver works great on Synapse 2.

    Maybe the dev team could do some test drivers to run Tartarus on Synapse 2.
     
    Razer.Speedcr0ss likes this.
  20. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for all the help guys! I've notified the team. I'll post once I have word from the team.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >