Razer Tartarus V2 controller D-pad sticking / glitch

Discussion in 'Razer Support' started by cpoChiD, Dec 10, 2020.

  1. pulseinteractive043

    pulseinteractive043 New Member

    I hate to be the bearer or bad news but I would not hold my breath on a fix anytime soon. This exact problem has persisted even prior to Synapse being released and goes at least as far back as the software that was used to control the old nostromo keypads. I have tried absolutely every fix under the sun on every software version they have released and on several different keypads and the only thing I have learned is that it is absolutely a software issue but must be deep deep in the code somewhere for it to persist as it has. The only fix i have found is to not use synapse and use reWASD to remap....you lose some functionality but at least you will stop uncontrollably running out into the open and getting your ass shot off
     
  2. pulseinteractive043

    pulseinteractive043 New Member

    here ya go, this seem familiar to everyone? This is from 2012....
    (*Omitted)
     
  3. Seegeth

    Seegeth Member

    For the past few years, I have used the Razer Orbweaver which uses Synapse 2, and I've never had this problem. Unfortunately, the Razer Orbweaver is hard to buy now, so I bought the Razer Tartarus.
     
    NoahArk620 likes this.
  4. NoahArk620

    NoahArk620 New Member

     
  5. CptCraptacular

    CptCraptacular New Member

    can vouch for rewasd been great since using that. Will prob just pay the £5 for the software as it's cheap, also they are working on putting extra features in the software for this keypad. they will, probably have rgb full macro etc working before razer get's anywhere at this point
     
    NoahArk620 likes this.
  6. Daisame

    Daisame New Member

    I have been trying to work through Razer support through twitter, since they don't seem to have an actual support page here (asside from these forums, that don't seem to get any responses from Razer staff). They want a video. I don't have equipment to make a video, not that I understand what possible use a video would be. This is not a difficult concept to understand how it is described. Maybe I should just send them that Battlefield video from 2012.
     
  7. Daisame

    Daisame New Member

    Twitter support is now saying that if I don't have a video of the issue, they cannot support me. WTF!? I am asking if that other person's video from 2012 would suffice. Razer needs to have a note on all their product postings that users must be able to take video of any issues to get support.
     
  8. topher82

    topher82 New Member

    I have the Logitech g13 and a Nostromo nut want to buy a new one since the ones I have are very dated. The Nostromo has 1 key that doesn't work altogether and 2 that stick, must be a on going issue with razer. The Logitech has a few minor issues but has be reliable for many years. Other than key sticking how is it and is it a mech keypad on the Tartarus?
     
  9. Daisame

    Daisame New Member

    Just to be clear. the keys on my unit don't ACTUALLY PHYSICALLY stick. THey just act as if they are. And it is not just the keys, the d-pad does the same. I love the layout of the Tartarus, and asside from the sticky inputs, the keys feel great. If it were not for the sticky input and the horrible customer service, I would highly recommend it. I used a Nostromo N52 when it was created by Belkin back in the day. Think I still have that pad somewhere. I have tried the Logitech keybpad but did not like it's layout nearly as much. I really wish they would fix the issue with the Tartarus because it would be awesome if not for this one issue.
     
  10. NoahArk620

    NoahArk620 New Member

    As similar as Nostromo’s issue is to the current Tartarus V2/Pro, you must focus on showing the video that is based on Tartarus V2/Pro. All you need to do is record the issue when it shows itself on your phone, and that is usually good enough.


    Tartarus Pro uses their latest Analog Optical Switches which functions very similar to red cherry mx switches.
     
  11. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hey everyone! Were you able to update your Razer Synapse to version 3.6.130.11816? Please let me know if it made an impact on your gaming keypad's performance. Our devs want to get feedback from this thread. I appreciate your PMs and responses.
     
  12. Daisame

    Daisame New Member

    The Problem with this request, is that it can be hard to record something that happens one every hour or so. I THOUGHT I was able to catch an incident last night, but my phone did not actually record it. The second problem with this request is that it should not make a difference. If they only want it to 'prove' that I have this issue, then fine, but it does not help anyone solve the problem. If they don't understand the problem, then ANY video that shows the same issue would suffice to show what the problem looks like.
     
  13. Daisame

    Daisame New Member

    I already am running this version. Unless it updated this morning without me seeing it, I had the issue last night so it did not solve it.
     
  14. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Thanks for letting me know. Does the same behavior happen when it is connected to a different computer? By the way, when and where did you buy the mouse? If you are residing outside the US and bought it from a reseller, please contact the store and request a replacement. Otherwise, submit a case to our Support Team or send me a PM so I can assist you in creating one.
     
  15. Daisame

    Daisame New Member

    Cosnidering it happened on my old gaming rig and it happens on my new freshly installed system... yes. I also have a case opened with support. [Vorgang: *Omitted]
     
  16. KidGixxer

    KidGixxer New Member

    Do any Razer employees use there own products?
    It seem hard to believe none of them have experienced this issue.
    It does seem to be widespread.

    Maybe someone at Razer should take one home, map the WSAD Keys to the d-pad and play any FPS for more then 1 hour.
     
  17. Yes its worldwide spread
    Even in japan lol (*Omitted)
    Use autotranslation and hold on bug, this is it.
     
  18. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Sorry for the oversight! I've corrected it now, DeadlyStingerPirates.

    Hey everyone. Razer is aware of the issue. That's why the Support and the Razer Insider Team is assisting whoever has experienced this issue. I may not have the ETA for the official fix, but I'll do my best to help our devs by forwarding each log from both Synapse and Windows that will be used during the investigation. Thanks for all your cooperation.
     
  19. the_novena

    the_novena Member

    The update to version 3.6.130.11816 did not fix the issue for me. In fact, if anything, it's happening even more frequently. (or perhaps that's just my jaded cynicism making it seem so).
     
  20. KAWAiiSONG

    KAWAiiSONG New Member

    Yesterday it happened just super often! in an hour, I got stuck about 8 times and completely different keys on both Tartarus and Naga Pro
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >