Razer Viper Ultimate Cable Charging Issue.

Discussion in 'Razer Support' started by I_am_Frisky, Jul 27, 2021.

Thread Status:
Not open for further replies.
  1. I_am_Frisky

    I_am_Frisky New Member

    My Razer Viper Ultimate has been plugged in for two days but is not charging. It's displayed as charging on Razer Synapse but still doesn't go past 2% . Tried changing and cleaning the port or using the dock but it still doesn't work. Please help it's a WIRELESS mouse for a reason.
     
  2. Razer.Xenon

    Razer.Xenon Retired

    Does the mouse still gets detected in the Device Manager when on a wired and wireless connection? For now, please clean reinstall your Synapse by following this guide. If the issue persists, send me the serial number of your mouse. I can use that to verify its model and look into a firmware-specific solution.

    *Thread locked to curb the conversation to PMs.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >