Razer wolverine ultimate not recognized on Windows 10

Discussion in 'Razer Support' started by DeepPeachnetworkfirst151, Mar 7, 2021.

Thread Status:
Not open for further replies.
  1. Hi. I have a problem with my controller since few months. I have bought it 3 years ago, and can't use it now since few months. It has stopped working on my computer without any reason.
    I have Synapse installed, and it is not recognized on it aswell.
    I also have tried to manually update the drivers of the controller, but windows says that i have the latest drivers. Could you help me please? I pretty much have tried everything.
    Thank you.
     
  2. Teruzond

    Teruzond New Member

    Do you have the Razer Controller Setup for Xbox app? Mine doesn't show up in Synapse either; you have to configure it through the Setup app which you get from the Microsoft Store.
     
  3. An-Xileel

    An-Xileel New Member

    yeah, but the app wont even download on the microsoft store, says "get" i click it and nothing happens
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >