Razor Huntsman Tournament Edition (TE) repeated/missed keystrokes

Discussion in 'Razer Support' started by JTonTheHuntsman, Jan 19, 2021.

Thread Status:
Not open for further replies.
  1. JTonTheHuntsman

    JTonTheHuntsman New Member

    Hello,

    Please fix the issue and provide an update before this blows up to fed level.

    I am having the same problem with my new Huntsman Tournament Edition keyboard as described in the following thread

    Razer Insider | Forum - Huntsman repeated/missed keystrokes
    https://insider.razer.com/index.php?threads/huntsman-repeated-missed-keystrokes.60790/#post-591212

    I also see in the forum and throughout the web that many people are complaining about this same problem. I do see that Razer has acknowledge this issue by providing a fix via firmware updates in some of the keyboards model but none of those firmware updates apply to my keyboard model (e.g. Razer Huntsman Tournament Edition).

    Here is the firmware site for various keyboard models. In some of the release notes you can see that some of the firmware updates attempt to address this issue, so it is a very real problem among your disgruntle user base.

    https://mysupport.razer.com/app/ans...16.623834944.1610914278-1698654310.1610223725

    Hence, I am not able to update to fix the problem. Synapse 3 does not provide a way to check the exact firmware of the keyboard, nor does it prompt for firmware update.

    Here are the specs to my keyboard.

    • Serial number: PM2033F36102657
    • Product NO: RZ03-03080200
    • Model NO: RZ03-0308 Gaming Keyboard

    I just bought this keyboard and spent $140 for this keyboard. The most basic function, "typing"...does not work right.
     
    Wolfy_425 and HyperBeastZero like this.
  2. JTonTheHuntsman

    JTonTheHuntsman New Member

    on the product support website, they indicated that we should try the forum first, but no one is responding to any of my posts. I need support for the product I purchase. What is the best means to get support?
     
    Wolfy_425 and HyperBeastZero like this.
  3. staticstring

    staticstring New Member

    I have got same issue, in my keyboard led not working too.
     
  4. staticstring

    staticstring New Member

    FOLLOW UP THIS ISSUE PLEASE :frown_::frown_::frown_::frown_::frown_::frown_::frown_:
     
  5. Microvan

    Microvan New Member

    I'm experiencing the same issue and looks like I have no other choice but to ask for a replacement. Have you find out anything?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >