Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

RBS (early 2019) + Core X (Radeon VII) = Code 12

Discussion in 'Razer Support' started by radioSmokyBlackOPAL840, Jul 16, 2020.

  1. I have spent roughly 7 hours digging through forums trying to find an answer to this, I just got a brand new Core X to pair with my Razer Blade Stealth (early 2019) and I cannot for the life of me get the eGPU to load up and let me use the GPU.

    I have removed the AMD drivers with DDU, reinstalling from Adrenaline, I removed that with DDU and tried to let Windows Update find the latest drivers, and still Code 12.

    I am running on Windows 10 (2004 Build 19041.388).
    Radeon VII (Driver version: 26.20.12028.2)
    Core X

    I am at my wits end, I don't know what else to try. I tried multiple thunderbolt 3 cables, I've tried re-seating the GPU. I've powercycled everything numerous times.
    I even completely reset my device and installed the latest version of Windows 10. I see people mentioning uninstalling an update ending in 5384 but I do not have that update listed.

    Is this the fate of AMD GPU's with the Core X? Based on my findings, looks like people have been fighting AMD GPU's for years and yet here we are 1/2 way through 2020 and I'm experiencing the same issue people were reporting in 2017.

    Any suggestions or additional troubleshooting steps that I should look in to? Should I return my Core X? haha

    I have an older GTX 980 TI that I am going to try with tomorrow just to see if that works...
     
  2. Stungone

    Stungone New Member

    I have a similar issue. I have a Thinkpad P52 (running Windows 10, version 2004) and an egpu. The egpu is housed in a Razer Core X with a Sapphire Radeon Vega 64 card. The card shows up in the Device Manager. Unfortunately, device status shows Code 12, this device cannot find enough resources that it can use. I also have a High Definition Audio device showing a Code 12 error. This seems to be a common issue with egpu's. I've read many forums with different solutions but the solutions don't seem to address Windows 10 version 2004. Does anyone have a solid fix for this issue?
     
  3. Any feedback to getting this fixed? I am having the same exact issue.
     
  4. Stungone

    Stungone New Member

    I attempted the pci.sys downgrade mod. I've read if you swap the pci.sys file from an older version of Windows 10 (version 1903), the device manager can allocate resources to enable an egpu. The pci.sys mod worked for my egpu, but in turn broke the Thunderbolt Controller. The Thunderbolt Controller now has a Code 43 error; Windows has stopped this device because it has reported problems. Still no success in solving this issue. There's a DSDT override mod some people have had success with; this is my next try.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >