Ripsaw HD 4K passthrough not working (Xbox One X)

Discussion in 'Razer Support' started by JabbaTheSmutt, Apr 12, 2019.

Thread Status:
Not open for further replies.
  1. JabbaTheSmutt

    JabbaTheSmutt New Member

    Currently a bit disappointed with this purchase, I replaced my old Avermedia capture card with the Ripsaw HD due to the 4K/1440p pass through feature as I was limiting my games and display to 1080p on my Xbox One X.

    I am aware that this card can still only capture in 1080p 60fps and that is fine.

    With the capture card installed, Razer synapse freshly installed, my Xbox One X is only giving me the option of displaying in 1080p and 720p.

    Bummer.


    I have connected the Xbox directly to the 1440p monitor I am using with both cables that I am using in the set up to make sure they are not a bottleneck, surprise surprise, neither of them were and both allowed my Xbox to output in 1440p. But as soon as I add the ripsaw HD to the equation I lose that option.

    As you can imagine i am quite frustrated as the product is not performing its flagship feature and only significant upgrade over the original Ripsaw.

    I am using OBS as my streaming platform of choice.

    Any help would be appreciated.
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there! Let me help you out with this. Can you share a short video of the issue? Also, have you tried resetting your setup to see if the issue persists? Let me know.

    Also, moving this thread to the support board.
     
  3. dethdealrpullen

    dethdealrpullen New Member

    4k works you have to enable it in display settings, advanced, video modes and enable 4k. What i wish worked was 1440P pass thru.
     
  4. dethdealrpullen

    dethdealrpullen New Member

    tech support said even though documents show 1440P passthrough, that you can only have 720P, 1080P and 4K. I thought maybe there was a setting somewhere in synapse that you could change it. I have confirmed atleast for now you cannot. I have sent feedback to the team at Razer in hopes we could get through a future firmware update. Also refresh rate of 120 is not supported and either is free sync. Ill update if anything comes out of it. As this will be a deal breaker for most streamers.
     
  5. kraus89

    kraus89 New Member

    Having the exact same issue. 1440p Samsung CF791 monitor only shows up as 1080p in Windows using the Ripsaw HD's passthrough. Also, my monitor is 100hz but it looks like this will only support 60hz, which will be a deal breaker for gamers that are used to higher refresh rates. Tech support said they would forward my ticket to tier 2. Will wait and see what comes of it and let you guys know.
     
  6. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi guys! Thanks for the feedback. Can you send over the case number to me through PM? I'd like to update it to let the team know that you reached out to us through Razer Insider as well.
     
  7. JabbaTheSmutt

    JabbaTheSmutt New Member

    Here is a video of the issue
     
  8. JabbaTheSmutt

    JabbaTheSmutt New Member

    Thanks dude. Help is appreciated
     
  9. JabbaTheSmutt

    JabbaTheSmutt New Member


    You heard anything?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >