Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Robin not recognised by USB 3.0 ports

Discussion in 'General Q&A' started by Pancode, May 31, 2017.

Thread Status:
Not open for further replies.
  1. pancode

    pancode New Member

    This is a very strange error, and I have no idea how or why this has come about. But it seems that another user has psoted about a similar issue. But in my USB 3.0 ports, my robin is not recognised and I get an error from windows. However, my USB 2.0 port works fine. I tested this with multiple phones and gaming devices (including my PS Vita, and other Android deviced) and all worked correctly in the USB 3.0 and 2.0 ports. Only the robin gave an error. I have tried uninstalling drivers and reinstalling them, and rebooting my PC and the phone. Nothing has worked so far. Any ideas as to what could be going on?

    Post with problem similar to mine: https://insider.razerzone.com/index...obin-with-pc-descriptor-request-failed.23463/
     
  2. bgiesing

    bgiesing New Member

    Are you using the stock cable that came with the Robin (as that's only USB 2.0)? I've not had any issues with both it and a USB 3 cable in both my USB 2 and 3 ports.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >