Static/buzzing noise when volume is high on the cable (Razer Kraken TE)

Discussion in 'Razer Support' started by Digster5, Jul 11, 2020.

Thread Status:
Not open for further replies.
  1. Digster5

    Digster5 New Member

    I purchased the Kraken TE a few days ago, and a slight buzzing is constantly playing. This gets worse when I talk to my friends, who sound like they all have TVs playing a loud static noise in the background. Even the discord mute and deafen noise have a static noise before and after.

    I purchased the Kraken X yesterday to see if it was just because my USB ports were faulty, and the buzzing is quieter on them but plays a very loud static noise through my microphone.

    I honestly have no clue what to do, I've read other forum posts about it and I'm pretty sure its because my PC isn't grounded, but I don't know how to ground it more than it already is.

    I have found that if I turn the volume down on the cable, the static is a little less noticeable, but in the manual that came with the Kraken TE it recommends turning the cable to the max, then controlling the volume on the USB controller.

    (This happens with both the front panel and back panel. but less on the back.)
    (Sorry if this sounds really confusing, I don't really know how to put it to words)
     
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    Hi there! Thanks for sharing your Razer Kraken TE's concern here. Have you tried connecting both headsets on a different device/computer? Does the issue happen even when Razer Synapse 3.0 and 7.1 Surround Sound is closed? Feel free to send me a PM should you need additional assistance.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >