Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Stealth BIOS update and Firmware Updates

Discussion in 'Systems' started by tydaawwg, Jul 7, 2016.

Thread Status:
Not open for further replies.
  1. Kokorone

    Kokorone New Member

    I only flashed the bin file.
     
  2. JETcoolCoolBlack681

    JETcoolCoolBlack681 Active Member

    Can you post some basic steps and screenshots?
    Do you have anything against current BIOS version?
     
  3. Apparently, there is a BIOS update for the new RBS that fixes the coil wine. However, I've been told that I need to send in my RBS for them to update the BIOS for me. I don't know if they'll allow us to do it by ourselves (still emailing support regarding this since I won't be able to send it in) =/
     
  4. Doaky

    Doaky New Member

    Yeah here you go: dl.razerzone.com/support/BladeStealth/Razer_Blade_Stealth_ECv62.zip

    And if that doesn't work I've uploaded it to my Google Drive: https://drive.google.com/open?id=0B8p_DIneuzvfUnd0dkgwa0xyek0

    You don't really need screenshots or a guide, it's hit the button and go. There is also a readme inlcuded
     
  5. softybear

    softybear Member

    wow, so that is something official from razer? it doesn't brick the trackpad does it? thanks again!
     
  6. Doaky

    Doaky New Member

    Nope. The EC fix is related to CPU power.
    It makes it so the Skylake Blade Stealth runs at full CPU power when connected to AC power

    And yeah, it's an offical patch from Razer
     
  7. softybear

    softybear Member

    Oh yes all right, it concernes the skylake and not the kabylake, sorry, I thought that was for the new razer blade :D
     
  8. Doaky

    Doaky New Member

    Haha no worries at all. It's still good to have all the files in one thread to take as needed.
    The Blade Stealth is a nice bit of kit, just has a few interesting issues associated with it
     
    softybear likes this.
  9. Hello everybody, I'm new in here.
    but i have a big problm with my RBS.

    i updated my drivers with auslogic driver update.
    i didnt realized that the BIOS also updated. after restart my bios changed into telcast BIOS which is the razer logo gone. and now all the driver such as audio undetected, trackpad cannot use, battery undetected, and the big issue also, my win activation also invalid because it was registered as previous system.

    please anybody can help?
    i tried to restore from the apps. the the result was the same.
    from the windows restore point before the update. same thing :slightly_sad:((

    Im not realy an expert about this
     
  10. Kokorone

    Kokorone New Member

    Use this BIOS file (http://www.mediafire.com/file/ek5ppnhala929mx/5-11.rom) with this utility (https://ami.com/download-license-agreement/?DownloadFile=Aptio_V_AMI_Firmware_Update_Utility.zip). Load the rom and check all the boxes to flash the bios file and it should fix your issue.
     
  11. Kokorone

    Kokorone New Member

    Also, ONLY APPLY what I just told you IF you have the skylake model of the razer stealth. I do not know how screwed you would be if you flashed that on a kaby lake model.
     
  12. zyf0330

    zyf0330 New Member

    Hello, I am in big trouble. Please help me. Thanks.
    I use ami utility to flash bin by 7z from exe of this http://dl.razerzone.com/support/BladeStealthH2/BladeStealthUpdater_v1.0.5.3_BIOS6.05.exe.7z. I run afuwinx64 that.bin /X to ignore error like "wrong rom id". Then, After I reboot, I cannot see anything in the screen. I cannot enter BIOS even. It is black screen from startup, one fan spins, usb keyboard doesn't work.
    I attempt several ways. One is put AMIBOOT.ROM into usb-disk and hold ctrl+home after poweron. Another is remove battery to reset BIOS. And remove hard disk to boot into DOS to flash rom. Nothing works.
     
    Last edited: Apr 26, 2017
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >