Synapse 2.0 Not Recognising Kraken 7.1 V2

Discussion in 'Razer Support' started by loadOrangeRedradio717, Jul 2, 2019.

  1. Synapse 2.0 is not recognising my Kraken 7.1 V2's.
    When I right click the Synapse icon in the tray I can see "Kraken 7.1 V2 Oval Edition" but in the software itself nothing comes up.
    I have tried every combination of uninstalling Synapse, reinstalling synapse, uninstalling the headset's drivers and reinstalling them and multiple restarts between these steps and I can't get synapse to work properly.
    When I first got the headset synapse recognised it, but as soon as my pc was turned off and on again synapse stopped recognising it.
    I've had this same issue with my old pair of Kraken 7.1's, but the issue was fixable with replugging the headset or re-opening synapse. The issue eventually fixed itself with my old headset but this time that doesn't seem to be happening and I can't find any short term solutions.
    Thanks in advance.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    How are you reinstalling the headset drivers? Also, what operating system are you currently running on your PC?
     
  3. Thanks for the reply,
    I was uninstalling the device through the device manager, making sure I opened every drop down and removing anything to do with the krakens. After that I would restart my pc and then plug the headset back in to reinstall the drivers. I also tried choosing “update drivers” in the device manager and choosing any other drivers I could see on my pc.

    I am currently running windows 10.
    Thanks
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    Please send me a PM with the serial number of your headset along with a screenshot of how it appears in the Device Manager. I'll take it from there.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >