Synapse 2 no longer detecting Blade late 2016 peripherals

Discussion in 'Razer Support' started by Irresistibletechno134, May 29, 2021.

Thread Status:
Not open for further replies.
  1. Hi there,

    I've had my blade for years. Never had an issue using synapse, and keyboard and touchpad/buttons have always functioned perfectly.

    A while ago (maybe 1 year or so), had a windows update and ever since then, the keyboard is no longer recognized in synapse and the hardware mouse buttons have completely stopped functioning. Nothing else happened at that time that might have caused this problem.

    The touchpad fortunately still works, as otherwise the laptop would be unusable without external peripherals.

    I've tried uninstalling synapse 2, tried synapse 3 (same result, no detection), uninstalled both and tried again with 2 from scratch but nothing detected anymore in synapse.

    Any ideas? Happy to supply any info needed, but this is seemingly caused by windows and synapse (and possibly something in razer's hardware being incompatible with newer windows updates). Would love to use my mouse buttons again, and get my keyboard lit up again so I can see it in the dark.

    Thank you.
     
    AnipR15 likes this.
  2. Razer.Speedcr0ss

    Razer.Speedcr0ss Speed Hunter Staff Member

    What other workarounds have you done so far? Have you tried connecting your peripherals to a different computer with Razer Synapse and checked if they are detected? Please repair the Razer Synapse by following the the steps from link and see if it helps.
     
    Irresistibletechno134 likes this.
  3. Hi there, thanks for your response.

    I've tried:
    I cannot connect my laptop keyboard or touchpad to a different computer as it's located internally in my razer blade. I do not have any external razer peripherals.

    Tried your link, pretty sure you didn't intend to send the link for "How to close or disable Razer Synapse 2.0", but instead one of the guides I've linked above or something similar.

    The part that frustrates me about all of this is synapse 2 functioned perfectly fine for many years until just recently. Nothing changed about my computer aside from windows automatic updates/potential synapse updates, so this certainly seems to be some conflict between windows 10 and synapse. Ideally synapse would allow me to install older versions, but as far as I understand it, the software automatically updates on program startup with no option to skip/disable them.

    Can't contact Razer support directly as my laptop is no longer covered under the limited warranty, and can't find an answer/solution for this anywhere on the internet but there's no way I'm the only person experiencing this problem.

    Any ideas?

    Thanks
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >