Synapse 2 window doesn't pop up

Discussion in 'Razer Support' started by CoolGreyurbancity478, Jul 25, 2018.

Thread Status:
Not open for further replies.
  1. Hi,
    As said in the title my Razer Synapse window doesnt pop up. Everything is fine when I launch the app, I log into my account, says it is synchronizing with the cloud, synching is done, and then nothing happens, my Razer Synapse process is working, everything is working, I just can't access anything cause the Synapse Window doesn't pop up...
    Anyone knows the fix? I would really appreciate it.
    Thanks
    EDIT: It is just like it's just working in the background and nothing else.
     
    Last edited: Jul 25, 2018
  2. Jenjar

    Jenjar Well-Known Member VANGUARD

    Same issue here and it does this on all of my PC's. It starts up closed, so you need to click the "Show hidden Icons" button on your taskbar (The little arrow pointing up by your volume button), and the Synapse logo should be there. Right click it, and you should get a couple options like close razer synapse, open razer synapse along with all of your different products. You can just click the 'open razer synapse' button and synapse should come up on your screen until you click out of it again.
     
  3. Trust me I tried doing it. I right click > open synapse and still nothing happens.
     
  4. Jenjar

    Jenjar Well-Known Member VANGUARD

    Have you tried reinstalling Synapse? Also, if your products support Synapse 3 I would move to that instead. I find it works much better then Synapse 2 but some other people have some issues with it since it is in beta still.
     
  5. Synapse 3 doesn't support Razer Blackwidow ultimate, and yes, I've tried reinstalling a couple of times.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >