Synapse 3.0 - blackwidow x TE keyboards

Discussion in 'Razer Synapse 3 Beta' started by PerliQ, Jan 21, 2018.

Thread Status:
Not open for further replies.
  1. PerliQ

    PerliQ New Member

    Today, I noticed that razer added support for the blackwidow x chroma in synapse 3.0, but not the TE model. Is it going to be supported and when? My keyboard is still stuck on 2.0 and my mouse is on 3.0 (lancehead TE).
     
    MrPonyy likes this.
  2. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Hi @PerliQ ,

    Blackwidow X TE is not currently supported on Synapse 3. However, if you don't want to use two Synapse versions, you can continue to use both devices on Synapse 2. Uninstalling Synapse 3 followed by a restart should make your Lancehead TE appear back in Synapse 2.

    Cheers!
     
    Last edited: Jan 23, 2018
  3. PerliQ

    PerliQ New Member

    Oh come on, now there is v2 TE.
    Pls add x TE ;-;
     
    Chromakid1989 and Smartplus50 like this.
  4. EFO00

    EFO00 New Member

    ya, please add it.. i just bought it here in Saudi Arabia 160 dollars because its the newest here.. razer please help, its not fair for us outside the US cuz we get products SO late AND PAID premium.
     
    Smartplus50 likes this.
  5. ardy19

    ardy19 New Member

    synapse 2 have lighting problem with blackwidow x TE. :slightly_sad:
    no one can slove this include razer support team.
     
  6. EFO00

    EFO00 New Member

    Hi.. what problem are you have with light?
     
  7. ardy19

    ardy19 New Member

    my blackwidow x te keep reset to spectrum cycling when i lock windows, replug usb or reboot windows. i must re open n re setting synapse lighting every time. i contact razer support many time with no luck.
     
  8. EFO00

    EFO00 New Member

    Are you using windows 10 or 7?

    I was having a similar problem, try different usb port at the back of the motherboard. ( some ports cause issues plz try it)
     
    Last edited by a moderator: Feb 1, 2018
  9. Joikansai

    Joikansai Well-Known Member VANGUARD

    I have no lightning issues on Synapse 2, on my Blade 14, Stealth and other brands laptops like xiaomi Air 13, so i think it’s your system failure. I have also Lancehead wireless etc all synced on turn on, wake up etc screen. Of course you have to be online to syncing your profile, if not I think it’ll keep last saved profile at off line.
     
  10. ardy19

    ardy19 New Member

    im using windows 10 64 bit, i also tried in win 7 32bit.
    i've been try all my usb ports. with no luck, the problem not gone at all. :slightly_sad:
     
  11. EFO00

    EFO00 New Member


    watch this video and try it( link above and update us, thanx)
     
  12. ardy19

    ardy19 New Member

    i tried that, and problem not gone.

    i'd make video for my problem.

     
  13. EFO00

    EFO00 New Member

    "Delete the xml-file in the C:\ProgramData\Razer\Synapse\Devices\Kraken 7.1 Chroma\Profiles folder and restart. Then set your profile and sync. " Tomhardware..

    if this didnt work whats mentioned above...then.

    i have a idea, u see the chroma works fine until u restart/sleep/shutdown right? and then you have to re-config it again once restarted? right.

    what application you have on the startup: click start, then type "msconfig" and see what start up and write down the application plz...
     
    Last edited: Jan 29, 2018
  14. Joikansai

    Joikansai Well-Known Member VANGUARD

    Provide the Support this video, tell them also your systems environment and things you already tried.
     
  15. ardy19

    ardy19 New Member

    i did delete this folder C:\ProgramData\Razer\Synapse\Devices\BlackWidow X TE Chroma\Profiles
    no luck.

    in startup program in msconfig i have enable
    - microsoft one drive
    - f.lux
    - epson status monitor
    - razer synapse
    - windows defender notification
    - windows desktop gadet
    i'd try disable all and only razer synapse enable.

    but my methode not work, it keep reseting to spectrum cycling. i did try in other computer in macbook keyboard work well, it doesnt reset to spectrum cycling. i found other who have problem same with me, many of that say the problem start on december i guess it happen after synapse update.

    yes i did, but until now razer support cant find where the problem come from.
     
  16. EFO00

    EFO00 New Member

    What is your mobo? asus??...

    if it work fine with the mac, windows and usb ports on the mobo is causing the reset..
    did you try to reinstall usb driver? from the mobo manufacturer..

    but please tell me the brand motherboard?
     
  17. ardy19

    ardy19 New Member

    i try in 3 windows cpu with gigabyte, asus motherboard and 2 laptop asus and lenovo.

    im not the only one who got this problem.

    https://insider.razerzone.com/index...e-always-reverting-to-spectrum-cycling.29410/
    https://www.reddit.com/r/razer/comments/7gcrl1/razer_blackwidow_x_tournament_edition_chroma/
    https://www.reddit.com/r/razer/comments/7qmuv6/blackwidow_x_te_default_problem/
    https://www.reddit.com/r/razer/comm..._to_spectrum_cycling/?st=jc0guzi1&sh=571aaf5b
     
  18. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Hi @ardy19 ,

    Thanks for the report. The engineering team has identified the solution to this bug and it will be released in a future patch after due testing. I will update an ETA on the release date when I know it.

    Cheers!
     
    EFO00 likes this.
  19. EFO00

    EFO00 New Member

    Thank god, cause a was running out of ideas.
     
  20. PerliQ

    PerliQ New Member

    Today i got a notification, that theres an update for synapse,
    IT FIXED IT!!!
    finally...
    gj razer :)
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >