Synapse 3.0 Issues

Discussion in 'Razer Synapse 3 Beta' started by kakerushin, Jan 19, 2018.

Thread Status:
Not open for further replies.
  1. kakerushin

    kakerushin Well-Known Member

    Firstly, I've never had issues installing Synapse 3.0. But the problem started right after I restarted my computer.

    1. Synapse 3.0 doesn't automatically start up - I have Razer Cortex installed and both Cortex and Synapse 3.0 are set to automatically start up. Cortex starts up without issues but by clicking the Razer notification icon once, "Synapse is not running" shows up.

    2. Running Synapse 3.0 manually doesn't run Chroma Studio automatically - Since Synapse 3.0 doesn't start up automatically, I always have to run it manually. It runs fine. The Synapse 3.0 window shows up but the Chroma effects I've set doesn't automatically apply, as if Chroma Studio doesn't run. To fix this, I always have to either click the Chroma module or go to Lighting on both my Keyboard and Mouse.

    I'm not sure if it's intended, but when I go to my Keyboard or Mouse's Lighting section, the Advanced Effects appear to be initially OFF, then turns itself ON.

    3. The last used profile on my Lancehead TE doesn't save - I have both Standard and Work profiles on my Lancehead TE. When creating the profiles, I believe the Work profile was the very first Profile I made. I last used Standard (named Default) but whenever I restart my computer, my Lancehead TE starts with my Work profile which I don't want to happen. Tried removing my Lancehead TE's profiles and created the Default profile first, followed by Work . Restarted my computer and Default profile is used automatically. Tried deleting all profiles and reversing the order of profiles created. Work is used automatically by Synapse this time.

    4. Synapse 3.0/Macro crashes while adding macro to Lancehead TE - When I try adding Macros to my Lancehead TE's Work profile, a window saying "The application encountered a problem" message and I had to restart Synapse to have it working again. Only then I was able to add Macros to my Work profile.

    To sum it up, Synapse 3.0 doesn't always start up automatically. If it does, Chroma Studio wouldn't start up with Synapse 3.0 and has to be executed manually. Finally, Lancehead TE always default on the very first profile created, not the last used.

    EDIT:

    Repairing Synapse 3.0's installation seems to have fixed the startup issue. The other issues still persist, though. Chroma Studio still doesn't start along with Synapse. It also always uses the very first profile created for any device and errors were encountered when binding Macros to devices the first time.

    <Update>

    Uninstalled both Cortex and Synapse 3 since tech advised me to delete all Razer folders in Program Files folders and ProgramData. Reinstalled both Synapse and Cortex. Startup problem's gone, Macro no longer crashes when editing button layout. Chroma Studio/Advanced Effects randomly stops. I doesn't matter when I'm browsing or gaming (games that are not Chroma supported). I know this because I have Wave set up on my Ornata Chroma and Lancedhead TE then suddenly they'd turn to Spectrum Cyclling. I'd have to either manually visit Chroma Studio or turn on Advanced Effects under Lighting for either device. This is incredibly frustrating.
     
    Last edited by a moderator: Feb 1, 2018
    Eskizho likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >