Synapse 3 Chroma compatible games not working anymore since update

Discussion in 'Razer Support' started by Madenleo, Jan 13, 2019.

  1. Madenleo

    Madenleo New Member

    Hi everyone,

    I've got a weird issue here with synapse 3. I am owner of a Razer base station and the Huntsman elite and chromabased games like Quake champions and Doom worked flawlessly with my peripherals before the last update. The update introduced Chroma Connect which contains all those apps that are needed in order to synchronize the lights with the game. This, however, does not work anymore even though the apps for Quake and Doom were present and turned on. Thus, I tried to deinstall Synapse 3 and deleted all my profiles but with no success. Now, the necessary apps for Quake and Doom are all completely gone and I can't retrieve them by starting the game. (Chroma option is active in the options menu of the game). So my question is whether someone knows what kind of issue that is and how I can fix that.

    -Synapse is turned on
    -Razer Chroma is activated ingame
    -Apps aren't shown in "Chroma connect" (they were before but it made no difference)
    -LEDkeeper.exe is not available either and was turned off before
    -It worked flawlessly before the patch
    -Chroma studio and all other functions are working perfectly
    -deinstalled and reinstalled Synapse 3
    -deleted all profiles and created new ones

    Any ideas?
     
    Last edited: Jan 17, 2019
  2. ocp15k

    ocp15k New Member

    My overwatch is gone but Diablo 3 works fine.
     
  3. Madenleo

    Madenleo New Member

    Someone has a solution for this? maybe the official support???
     
  4. Jurare

    Jurare New Member

    for me it is vice versa. Everything works fine, but my diablo 3 didn´t want to start. But, after i reinstalled the Razer Apps (Cortex, Synapse 3, Central etc.) everything worked fine again. Dunno why, everything was already up to date before...
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >