Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Synapse 3 constantly disconnects all 4 Razer devices

Discussion in 'Razer Support' started by sleekRhythmload597, Mar 28, 2020.

?

How often does your Synapse 3 crashes\looses your devices?

  1. Every minute.

    22.2%
  2. Every 10 minutes.

    77.8%
  3. Every 30 minutes.

    0 vote(s)
    0.0%
  4. Never. Works like a champ.

    0 vote(s)
    0.0%
  5. After ... years with Razer I finally switched to Logitech.

    0 vote(s)
    0.0%
Thread Status:
Not open for further replies.
  1. sleekRhythmload597

    sleekRhythmload597 New Member

    Synapse 3 constantly disconnects all 4 Razer devices:
    - Ornata Chroma
    - Mamba wireless
    - Nari
    - Tartarus Pro


    I think NARI Bluetooth connection is the problem. Works fine for now plugging Nari Bluetooth receiver to Razer USB wire and adapter for Mamba and putting it as close to the Nari headset as possible.

    It happens in-game and in some programs (video and image editing) at different intervals, from 1 to 30 minutes.
    - Nari headphones beep in different patterns,
    - Mamba can't change DPI on-the-fly in wireless mode,
    - Tartarus PRO's lighting is on, but buttons are unresponsive, except for Alt/Change profile button somehow,
    - Ornata's FN button doesn't work,
    and when I look at Synapse pages for all connected devices, no profiles are loaded (the list is blank), all batteries show zero charge, and, sometimes, Synapse is unresponsive.

    Every time I have to go to the desktop and either close all Razer related apps or finish all Razer processes, then run Synapse again. And after several minutes repeat.

    What I did so far:
    - Updated firmware for everything, except the Tartarus Pro, as I can't find it anywhere (Synapse should do it automatically anyway, right?).
    - Clean reinstall of Razer software as explained on Razer support page.
    - Reinstallation of all USB and hid-interface drivers.
    - Stopping Windows from turning off USB ports for power saving.
    - Different USB ports.
    - Two computers (PC and Laptop).
    - Reinstallation of Win 10
    EDIT: also tried to connect the devices one by one. the only devices that are working together without Synapse 3 problems are Mamba+Goliathus+Ornata. Plugging in Tartarus Pro or Nari and starting the abovementioned apps, breaks Synapse 3 somehow and they all start to "disconnect".

    I have contacted support with this issue and been approved for check-up/replacement of the Tartarus Pro and Nari headset, but:
    1. I think this is not a hardware issue.
    2. There is no way to replace my devices at this time due to logistic problems, caused by quarantine.

    System:
    - Win 10 Home 64 (was Win 10 Pro) 1909 with all the updates
    - AMD Ryzen 5
    - RTX 2060
    - 24 GB Ram

    So all I ask is for beautiful people in tech support to consider this problem since they certainly know much more than I about the Synapse 3 Beta intricacies. And, of course, be extremely cautious and healthy in these difficult times.

    Thanks in advance!
     
    Last edited: Apr 11, 2020
    Itaykuper and xldyelx like this.
  2. Eluryh

    Eluryh New Member

    Same here.

    I have a Blackwidow Chroma, a Mamba TE, a Goliathus Extended Chroma and a Kraken headset.
    Synapse keeps disconnecting every few minutes, losing the lightning effect and resetting it, like if I was unplugging and plugging again the USBs on my computer. The fact is that, if I close the Synapse 3 app on tray, of course the lightning effect will remain as a cycle effect, with no control to it, but my devices will not reset anymore. So I think the problem lays on Synapse.
     
    sleekRhythmload597 and xldyelx like this.
  3. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for posting your concern here. What's your current Razer Synapse 3.0 version? Please send me a PM together with a video showing the issue. Let's continue from there.
     
  4. xldyelx

    xldyelx New Member

    There needs to be better troubleshooting than" sending a video"

    The event is less than 5 seconds and is random and unpredictable. I would have better chances getting a shooting star on camera.

    Does Razer not have an event log or I can send in Windows Event logs?

    Ironic thing is it just did it twice while I was typing this...both times...couldn't get my phone out fast enough to video it.

    Synapse 3
    3.5.331.33010
     
  5. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Your point is well taken. Please click here and follow the steps on how to gather Razer Synapse 3.0 logs. Once done, please save the compressed files via Google Drive or to another online drive account then send the link via PM. Let's continue from there.
     
    xldyelx likes this.
  6. xldyelx

    xldyelx New Member

    Sent!
     
  7. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Thanks! I've replied to your PM. I'll wait for your follow-up.
     
  8. Was there evera solution to this? Ran Synapse 2 with 0 issues for years. Picked up a new Basilisk mouse and now that I am solely running on Synapse 3, randomly disconnects the mouse and keyboard. Sometimes it does it while I am opening an application but it happens randomly and I can't replicate it.
     
  9. sleekRhythmload597

    sleekRhythmload597 New Member

    My problem was the Nari headset connectivity. Constant reconnections were temporarily solved by connecting the bluetooth dongle through the Razer extension usb cable. You can try that, and check if the bluetooth connection is messy.

    Also, if you got all the software updates for the Basilisk and Synapse, first try clean reinstall with all the drivers as they say in manual here somewhere (if you want I'll provide a link).
     
  10. Hmm, weird. So I have the Ornata keyboard and the Basilisk v2, both are hardwired. I went in and took a log, uninstalled the drivers, and then cleaned up all the files and did a fresh install. Happened almost 5 mins in the second I opened Outlook. It honestly seems like the devices are timing the connections, but they're not getting an accurate reading so the application is triggering Chroma Studio (or whichever links RGB to applications) since it checks to see if it is an app linked to a profile.
     
  11. Just ran through that clean install process you referring to and it may have been the source of the issue. All the devices that logged the event errors today on the crashes were all there but hidden. Cleaned everything up and we'll see how it holds up. Thanks!

    Link to clean install doc - https://support.razer.com/articles/1699349771
     
  12. sleekRhythmload597

    sleekRhythmload597 New Member

    Yeah, forgot to mention tons of hidden HID drivers. Here's to hoping clean reinstall does the trick.

    Btw I also had problems, mostly ingame though, with overlapping devices, i.e.: gamepad/non Razer bindable keyboard, or controller. Their old drivers might stay stuck in the system, preventing Razer's stuff work processes. Or they or Razer devices sometimes must be physically unplugged for games to work properly. Don't know if it's relevant to you.

    Good luck!
     
  13. Not a single hiccup all day through constant use. Dam, good call dude. I really wish I would have had a script that could've deleted them all because it about 40 mins of just checking to see which, if any, of the hidden drivers had the errors logged. Regardless, it seems like it was just fighting for drivers. Not sure why it's an issue on Synapse 3 and not Synapse 2 but if that's the case, a driver utility cleanup should run when you migrate from 2 to 3.

    Thanks again!
     
  14. JDREDD81

    JDREDD81 New Member

    Equipment being used:
    Blackwidow Chroma
    Tartarus Pro
    LED Development kit
    Nari Ultimate

    I have been having similar issues. I just recently got the Tartarus pro and would just disconnect mid game.... Not fun when playing BR....

    I have tried to un install and re-install from the Razer support and still same issues. Before the Tartarus pro I had the LED development kit and the blackwidow LED just stop working. When I exit the Synapse everything is working as intended but just would have them goto default breathing on the LED.... Spend tons of money would like all the features to work. I think Synapse 3 is flawed way past the original code..... Guess thats why its been in Beta for several years....

    Also Support needs to post their findings in the forum and not just ask people to PM them and then nothing is said...Like they are hiding their messed up software..... Until there is a full fix, guess ill just get something else....
     
  15. Make sure you have all the additional items noted as necessary in the link to perform a clean install. It even says that having a different version of Microsoft .NET Framework or MS Visual C++ can cause issues (so yea, their software needs work).

    So, unplug all your Razer items except the mouse and keyboard and run through Steps 1 - 5 in the link above (https://support.razer.com/articles/1699349771). If you have a regular keyboard and mouse that isn't Razer, use those.

    Before restarting again, download Synapse 3 and keep it in your downloads folder (Synapse 3 Download - https://www.razer.com/synapse-3):
    1. Make sure that you go through every single item in Device Manager and find anything that is hidden and not being used. You'll be surprised how much stuff actually comes up.
    2. Then, go to file explorer and search the ENTIRE computer for keywords such as "Razer" and "synapse". Many of the files are hidden across multiple folders and you'll see how much stuff is still in your system.
    3. Go back to Device Manager, unplug the keyboard (and the mouse if you have a generic one to connect as a replacement), make sure you are viewing hidden devices, and scan for hardware changes. Delete the residual drivers leftover.
    4. Restart
    5. With your Razer devices still disconnected (or just the mouse plugged in), go and reinstall Synapse 3 from the downloads folder.
    6. Once it's done, run Synapse 3 as administrator (right-click > run as admin) and check for updates.
    7. Restart again.
    8. Open Synapse 3 as administrator again and check for updates one last time. Leave Synapse 3 open as administrator
    9. Before plugging in devices, go back to device manager and check for hidden devices again and make sure nothing is still there (just in case).
    10. With Synapse 3 running as admin, plug in your devices and let them install. Once done, check for an update again

    Hopefully, this helps fix it for you because it resolved my issue completely.
     
  16. Razer.SpeedCr0ss

    Razer.SpeedCr0ss Speed Hunter Staff Member

    Hey everyone! Thanks for posting your concerns/workarounds here. Was everything covered? Feel free to send me or any mods a PM should you need additional assistance. I'll be locking this thread now.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >