Synapse 3 Crashing

Discussion in 'Razer Support' started by Akimbowles, Nov 15, 2020.

Thread Status:
Not open for further replies.
  1. Akimbowles

    Akimbowles Active Member

    As the title suggests, Razer Synapse 3 constantly crashes.
    When I boot up my PC, it prompts me to launch Synapse, I do, and it has the little loading screen, then... nothing. It never launches, and about 10 minutes later, I'll go to the icon in the system tray and relaunch it, for the same thing to happen.
    Other times, it will actually launch! Although this is a rare occurrence.
    However, on these times it actually launches, I click on the app to do something, and am presented with an error message saying "The application encountered a problem, please exit synapse and start again" (as seen in the image). Which I do restart it, only to have it not launch again.

    Now, I have tried a fresh install, and that hasn't fixed it at all. It's been like this for months now, and I just want it fixed :slightly_sad:
     

    Attached Files:

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >