Synapse 3 Studio Crash - Fixed

Discussion in 'Razer Support' started by Akimbowles, Dec 23, 2020.

Thread Status:
Not open for further replies.
  1. Akimbowles

    Akimbowles Active Member

    Okay, so title says it all, and damn I feel dumb.

    Original issue was that Synapse worked fine, except if I tried to access the Studio module. Once I clicked that button, the application would crash, and a dialogue box would appear indicating an error had occurred and it needed to restart, only for restarting to fix nothing!

    For over a month now, I had tried troubleshooting in so many ways from advice on various forums, with nothing working... I tried fresh installs (deleting all Razer/Synapse software, and deleting all files and folders for Razer/Synapse software on all drives), with nothing working.

    Yesterday, I had an epiphany, and noticed that whenever I would log in on Synapse, it would say it was syncing settings from the cloud.
    So I deleted my Razer account. Waited 24 hours, and set up a new one (using same credentials, so go to recover my Insider info), but in doing so, it wiped all of the saved profiles in the cloud for this account.

    And it worked! Synapse Studio worked.
    I think that when I was using Synapse 3 in the beta, one of the lighting profiles I had created had become corrupted, so every time it downloaded it from the cloud, it would cause it to crash.
    I can't believe it was that simple, and I'm kicking myself for not trying that sooner!

    TL;DR: Deleted Razer profile to stop it downloading corrupted lighting profile from cloud.
     
  2. pottro563

    pottro563 New Member

    any downloaded chromaeffects extension files I download never show up as an option to import the profile now for me... I have tried re-downloading the files reinstalling razer synapse and relocating the files and still cant find them when I try to import...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >