Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

[Synapse 3 update] // 18-Oct-2018 // Release announcement

Discussion in 'Razer Synapse 3 Beta' started by RazerThe_Fiend, Oct 18, 2018.

Thread Status:
Not open for further replies.
  1. Ringowu1234

    Ringowu1234 Member

    Before the update I could bind the mouse keys to "change to lighting profile x" (sorry I don't know the exact words as mine is in Chinese)

    But now the option is gone. Is this intentional?

    Mouse is Naga Hex V2
     
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    Mr. developer still in hue module while you switch entertaintment profile created in hue app all devices from hue reset they position in chroma app to center and it's the same bug as this where you add this module to synapse so great work. When you set enterteintment profile and sign to it hue devices still you lose control on other devices like hue app or homekit synapse take full control of them great work still not fixed. On new update i dont know what you do but Nommo Pro and more quite then on privious build. On huntsman elite mulimedia dial after windows start mute status while the speakers are turn on color change when you change volume it's from privious build and go to new one as well.

    Sorry but i stil dont see any improvment in synapse in case of devices wtill the same issue and bugs you just make underhood improvments and call it repair. Like someone said before I love razer hardwere is in my mind the best one design. control quality, warranty when i set-up chroma is bright and i have full control what i want to make but the softwere is still take away all the glory of device when you go to home and plugin into pc or mac and the train start when you open game bug or issue someone spend alot of money to have not fully compatibility devices with their functions.
     
  3. I recently purchased a huntsman elite keyboard and a mamba elite mouse. I have an issue where synapse 3 doesn't open with windows for some reason? I'm also having issues with color profiles loading at all etc..

    I have to admit, I went from having a perfectly working older mouse and keyboard " razor setup as well " to a whole new setup and feel ripped off after dealing with synapse 3. Can I please use synapse 2 now again, please?

    Edit:

    This link here " https://linustechtips.com/main/topic/692140-razer-synapsesurround-does-not-autostart/ " has the solution which I would figure would be the solution but really razer? The post is from 2016!!

    Edit: Never mind that didn't fix the issue either. It's listed under the startup apps folder now and the startup apps tab in task manager. THIS IS A JOKE PLEASE LET ME USE MY MOUSE AND KEYBOARD THAT I JUST PAID $300 FOR!!!!!!!!!!!!!!
     
    Last edited by a moderator: Oct 22, 2018
  4. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    I've spoken about this one before... the lack of a distinct "release" event for scroll wheel makes it much different from any other key/button. Our stance is that it is better to not have certain features rather than release them with issues we know would be game-breaking.

    All other complaints that you mention are new specific features to aid your workflow, not strictly bugs. Don't get me wrong, we value that feedback too, they are completely valid requests and we consider them alongside everyone else's feedback when implementing new features. However, as mentioned previously, before we implement any additional features, we're purely focused on making sure the program behaves the way it is supposed to for the time-being, and making sure that every bug that has been reported gets fixed.

    I'm not 100% sure about this (will have to double-check), but I believe Destiny 2 in specific is a game which blocks external programs (such as our game manager service) from checking its active state, so Synapse can't tell when it is in foreground which might be causing this.

    Could you verify if this issue also persists for you with other games or applications as well?

    I wrote the tech-specs for Philips Hue module in Synapse so rest assured I know more about how it works than maybe 4 other people in the world. ;)

    The Chroma apps/games directly control lighting of Chroma enabled devices (and that includes Philips Hue). The toggle in Philips Hue tab does not control game interactions with Hue lights. If you want to disable Chroma integration for specific (or all) games, you can do so in Chroma -> Apps tab.

    You don't need to explicitly set a "Default" profile. Whatever profile you manually select in Synapse becomes your "Default" profile, and Synapse has further provisions to automatically switch to a different profile based on foreground apps. If those apps are no longer in foreground, it goes back to the last manually-chosen (aka default) profile.
    I did test aggressively switching keymaps during gameplay when I was testing and didn't experience any delay what so ever. Although admittedly I did not try rapidly switching 40 times in a row (since none of the games I tested with required it).

    That being said, if you're still seeing issues, that's completely valid and we'll look into it further... Could you share specifically what games you're testing the Tartarus V2 with? I'd be happy to add those games as test cases for our QA team.

    Yup, acknowledged. We had one more report of this bug, and is being worked on for the next major patch.

    I'm sorry I can't read Chinese, but I tried switching language and I can still see the option. Can you share a screenshot how it looks on your screen?

    upload_2018-10-23_15-15-58.png
     
    Last edited: Oct 23, 2018
  5. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    I'm very surprised this is still happening. We've tested on 100+ different configurations and we absolutely can't replicate this what so ever. I've created a dedicated thread to have this addressed, please click here.
     
  6. Lusabit

    Lusabit Active Member

    Autostart problem: they check at Systemconfiguration -> Autostart (former msconfig), if something is disabled ?

    I had a similar problem with another type of driver, deinstall, install, nothing helped. Until I looked there.
     
  7. bestwatchFlirt855

    bestwatchFlirt855 New Member

    Just got the huntsman elite keyboard. Loving it so far but I cannot seem to get synapse 3 to work, it just shows up with a transparent screen and wont open any window. The installer shows the actual menu and button for about half a second and then becomes transparent.

    upload_2018-10-23_15-13-47.png upload_2018-10-23_15-15-24.png
     
  8. BlackFireDragon

    BlackFireDragon Well-Known Member

    So tell me one thing pre-build prodiles are chroma ones only for lightning made by company that created a game like Overwatch profile created by blizzard. On chroma tab we can made own prodile so hat is the diffrence that pre-made one overwite hue module and own cannot do this. Own or pre-build profile by game developer are controled by the same softwere in this case by synapse that allow or disable sending commands to specific device listed in that section.
     
  9. Zer0_Kelvin

    Zer0_Kelvin Member

    Tartarus V2 Scrollwheel:
    So why can't you have it where: IF Scrollwheel kicks off a macro THEN disable scrollwheel from doing any further commands until macro finished executing? The duration of the macro dictates the amount of time the scrollwheel is disabled, not any 'release' event in itself. I presume your software is smart enough to turn on and off a button or even the scrollwheel.

    1. My second gripe I suppose with the software is the inability (AFAIK that still exists) to assign unique D-Pad (8-directional or 4-directional) to each Keymap within the profile.

    2. My last gripe is (AFAIK still exists) the inability to assign multiple profiles to the same game. (So as to accomplish making mappings for unique characters within the game (esp. MMOs where one may have multiple classes and those classes require different keymappings etc).

    The above two items you're stating are new features. Yes, maybe they are.
    HOWEVER. Are you not a gamer? Are the people who are designing this not gamers?
    Do they not know that there are plenty of games out there where one needs to specify a different profile and commands for different character classes within the same game??
    Thus the NEED for the above two points.

    Maybe you think it is unreasonable for your customers to expect such functionality. At least, this is the feeling I'm getting. These are gaming peripherals. The focus needs to be placed on improving features(RGB Lighting effects are less of a priority) while at the same time keeping old tried and true features(like the scrollwheel macro).

    I am not very impressed with the decisions your company has made thus far. And as I'm sure you're well aware, I am extremely dissatisfied on what Razer did when it comes to selling the hardware portion of the product when the software portion wasn't ready.
     
    Lusabit likes this.
  10. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Overwatch integration is not a "profile". Synapse does not control it. The game directly sends lighting commands to all Chroma-enabled devices. Synapse does provide a manual override for it, which is in Chroma -> Apps tab.
     
  11. zion563

    zion563 New Member

    "I did test aggressively switching keymaps during gameplay when I was testing and didn't experience any delay what so ever. Although admittedly I did not try rapidly switching 40 times in a row (since none of the games I tested with required it).
    That being said, if you're still seeing issues, that's completely valid and we'll look into it further... Could you share specifically what games you're testing the Tartarus V2 with? I'd be happy to add those games as test cases for our QA team."

    Every game I've played. It isn't so much as I aggressively click the dpad (only did to test) it's in all applications, even when I am in default with nothing running just Win 10.
    What happens is that after a period of time in ACTUAL play (like 15 minutes or so depending on type of game) the dpad Forward push and release becomes suddenly delayed. I can reproduce at any time. I can't be sure how many presses it is but over 40-50 maybe more. When I play games I have my resting Keymap as Keymap 3. I have the device set so when I push forward with my thumb, it switches to keymap one, which I have numbered 1-= on keys for combat and hotkeys, and set to release back to keymap 3 when done. This is occuring constantly in games of all kinds. I found out the hard way that every game at some point becomes unplayable because of course a 5-7 second delay makes you dead and is exasperating. As I have said before and reported the same problem now multiple times, Every Nostromo/Tartarus device going back to Belkin N52 I have mapped the same way with NO problems till now. I had included a link to the thread where I discuss it and at least 2 others have exactly the same issue, one guys using for autocad. I can reproduce it at any time. It's seems like after a certain number of press and releases it builds up a queue of commands waiting to fire . If I had a way of doing a video I could show you right now. I have actually just done the test and sent in logs in bug report area twice.
    If you do test again-just keep pressing over and over fairly rapidly like you were in a fairly active game, since you arent going to sit down at a session and play it's the only way to re-create it. I can take a video maybe but not sure how to get it to you of it happening.
     
  12. zion563

    zion563 New Member

  13. Chaos.Blades

    Chaos.Blades New Member

    Bug fixes are great but any update on Razer Naga Epic Chroma?
     
  14. BlackFireDragon

    BlackFireDragon Well-Known Member

    So the pre-build profile is not a profile but bridge between synapse and game and all config is in game ? Tell me one thing why you give support for profiles that are created for synapse 2 without new module like hue and dont force game developer to update the profiles to new softwere becose here is a problem and you still claim it's a hue firmware issue.
     
  15. MagusRazer

    MagusRazer New Member

    So since there is no activity in this thread (https://insider.razer.com/index.php?threads/need-help-with-3-3-1012-101219.43428/#post-462995), I will post here what this update broke.

    Problem with polling rates in your latest Synapse build explained again:

    Whenever I switch a profile, it doesn't update the polling rate and it stays at 1000 Hz even if the new profile has a different rate. If I want to use 125 Hz, I would have to manually switch polling rate to 500 or 1000 and then switch back to 125 Hz.

    Here is the the video with proof: https://streamable.com/a404c

    After 2 new updates that polling rate issue is still not fixed yet.
     
  16. BlackFireDragon

    BlackFireDragon Well-Known Member

    Today i cheack my "Nommo Pro" and the funny thing is any of the settings in device is sign to profile but to synapse itself so when you switch a profile any of the settings dont change like volume, bass level and audio enchancment it's so annoying then you open game and must go to synapse to manual set-up everything only sor game and after game change it back. I dont know why developers give profile that change only name nothing else.
     
  17. Maximusisback

    Maximusisback Well-Known Member VANGUARD

    I'm not sure if this is the right thread, but I wanted to know how to claim the z-silver for taking part in the Razer Synapse 3 Beta. Do I have to contact a mod or wait for my feedback to be reviewed?
    Thx guys
     
  18. NahuelCC

    NahuelCC Member

    Oh, another crappy update. Let's see which function you break this time.
    Time to create a restore point before trying this one.
     
  19. BlackFireDragon

    BlackFireDragon Well-Known Member

    New issue with Nari lineup mic when any of the settings is enable like volume normalization, ambient noise reduction or vocal clarity mic dont pickup any sound when they are disable mic work without any problem.

    Edit:
    Also Nari after reconnect reset sound volume to 50 every time ignoring user choise.
     
    Last edited: Nov 20, 2018
  20. Veyska

    Veyska New Member

    Is there a way to force an app update? Checking for updates doesn't result in anything and I'm wondering if this might help the problem I just posted a support thread for (in the wrong forum, oops, I'm having a really crummy day sorry).
    (Edit - *snip* Was mixing up version #s between modules or something, but my Trinity's still not behaving properly. Dangit.)
     
    Last edited: Nov 30, 2018
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >