Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

[Synapse 3 update] // 20-Sep-2018 // Release announcement

Discussion in 'Razer Synapse 3 Beta' started by RazerThe_Fiend, Sep 20, 2018.

Thread Status:
Not open for further replies.
  1. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Hi All,

    Continuing our efforts to polish Synapse 3, we have been tirelessly working on bugs/quality improvements. Since last major update, we've released a couple of minor updates/hotfixes, and today we're releasing another major patch which addresses over 300 issues of varying magnitudes.

    Some of the most notable issues fixed with today's patch (Version 3.3.918.91818), are as follows :
    • Synapse auto-start issue at boot in certain conditions
    • Synapse no longer creates a desktop shortcut after each update
    • Duplicate devices appearing in several places in the UI
    • Fixed various scenarios where live preview was not working as intended.
    • Devices disappearing from Chroma Studio
    • Improvement in UI responsiveness for specific situations
    • Device positions resetting in Chroma Studio after Synapse update
    • Abnormal behaviors after sleep/resume/hibernate operation
    • Fixed Issues with sensitivity stage and X-Y sensitivity toggles for mice
    • Fixed issues with delayed launch under limited/no network connectivity
    • Fixed issues in use cases with multiple windows accounts
    • Hypershift binds sometimes not working
    • Multimedia/Function keys not working as intended when pressing Fn+F1-12
    • Sensitivity clutch function intermittently not working
    • Goliathus Extended now supports left-handed orientation (keyboard on right, mouse on left)
    • Added diagonal movement options for joysticks on Tartarus V2 (allocated by default to 8-way D-Pad controls)
    • Several Chroma Studio issues related to Chroma HDK orientation/positioning
    As always big thank you to all the individuals that take time to provide detailed feedback reports and logs, without which it would be impossible to validate, reproduce and fix these bugs.

    Cheers!
     
    Last edited: Sep 21, 2018
  2. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Future outlook :
    - We currently forsee 2 major bug-fix patches before we can get rolling on the pending roadmap items.
    - Import/Export of profiles in Chroma Studio will return in the next major patch (very rough ETA of 2nd week October), along with another batch of bug fixes.
    - Further down in Q4 we will see release of the some of most requested feature improvements (I have a 7 page list of assorted requests) including inter-device profile switching, device profile+chroma effect switching with single keybind, embedded tutorials, toggle for toast notifications and a few mystery features to make everyone happy
    - Q4 will also see the public release of the much anticipated "Chroma Connected devices program", more details to follow in due time.
     
    Last edited: Sep 20, 2018
  3. klepp0906

    klepp0906 Member

    hrm. no mention of the auto updater quitting, nor the profile switcher stopping working due to gamesmanagerservice not finding any games.

    Hopefully those fall under "abnormal behaviors after sleep" and i just never tied the two together.

    heres to hoping. Glad to see an update regardless. Will rip this out and reinstall momentarily ;p

    Ty for the roadmap :)

    ah well, rip.

    gamescanner service starts when i try to link a game and boosts itself to the top of my cpu usage (so is running) but still finds no games and just runs perpetually.

    look at what you changed a few releases back - thats when it broke and hasnt worked since :slightly_sad:

    heres to hoping for next month. Until then no auto changing profiles for me which is a huge part of why I bought into the new stuff.
     
    Last edited by a moderator: Oct 17, 2018
  4. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Hello,

    I understand that you have shared your logs and other relevant information with the customer support team previously. It seems to be a very isolated case which hasn't yet been replicated internally, but our engineering team is already looking into possible defensive fixes for this.
     
    Last edited: Sep 20, 2018
  5. klepp0906

    klepp0906 Member

    Correct. Logs were shared and I’m available to help with anything else they need along the way.

    As I mentioned. It was working a few months back. First to go was the toast notifications regarding profiles being switched. (They still switched however and this is probably unrelated)

    Then it started picking up roms from steam when it scanned instead of just pc games. Ending with it trying to scan THOUSANDS of games which it could still be doing ending in some sort of timeout. (Really need a way to omit that or omit directories. Something. Regardless)

    Now I’ve purged it entirely. Registry program/appdata and all. Reinstalled. Simply will not pick up games anymore. No matter which hdd. Internal. External. Ssd. (Which could also be part of the issue. Perhaps having issues handling multiple disks now?)

    Just some thoughts.
     
  6. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    It might have some relation to the problem (can't say for sure), but we definitely do handle multi-disk scenarios (internal and external), my games are split across 3 HDDs/SSDs as well, and it fortunately (or unfortunately) hasn't misbehaved for me yet.
     
  7. unsponsoredgeek

    unsponsoredgeek New Member

    I am just waiting for my Razer Blade Steath 12.5" (6500U) and Core V1 to be included in Synapse 3 so I don't have to run Synapse 2 at the same time to get the surround sound and other features active.

    No Razer Left Behind!
     
  8. BlackFireDragon

    BlackFireDragon Well-Known Member

    Everything great but i ask where is support for older devices like naga epic chroma many people on forum ask for it, siren pro with must have synapse softwere to run on windows and orbweaver ? Another thing where is on this program chroma partnership Asus ? Most players in this days their motherboard and aura sync ! I dont quite get why people are pushed to use beta softwere were are not supported devices they use. I play MMORPG and now i must use 2 difrent softwere on my pc with takes resorces from my gaming expiriance.
     
    Chaos.Blades and unsponsoredgeek like this.
  9. PalZer0

    PalZer0 Member

    Is this referring to how my monitor keeps waking itself up while the Synapse service is running?
     
  10. aecro

    aecro New Member

    We haven't seen any "old" devices added for a while now. Is it safe to assume you're done with that and only new products will be added?
     
  11. PalZer0

    PalZer0 Member

    That would be in the "pending roadmap items" referred to in the second post. Addition of old devices was suspended due to the large number of bugs that surfaced when a number of popular devices were added (the BlackWidow Chroma V2 and DeathAdder Elite in particular).
     
    unsponsoredgeek likes this.
  12. klepp0906

    klepp0906 Member

    fwiw - auto updates also stopped working in this build. Works when i first install, then stops. (potentially after a sleep?)

    If i try to "check for updates" from synapse. Nothing happens. No spinny circle indicating its checking etc.

    If i try to check from Razer central, its turned off (even though i enabled it upon fresh install) and cannot re-enable it as its greyed out.

    Incredible all these things worked months back without issue. We are at your mercy. Evidently the software is truly beta which is fine. The problem arises when new devices require it and it still doesnt work properly.

    Oh well, we'll see what happens in another month or two when the next update is pushed.
     
  13. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    This is the only instance of any such issue I've heard. Could you share a screenshot of how it looks?
     
  14. klepp0906

    klepp0906 Member

    upload_2018-9-21_8-36-56.png

    notice the mouse cursor on top of check for updates and wont even turn active to click. If i restart the pc it'll turn active for a click but then the circle that spins next to Razer Synapse just spins for a few minutes and does nada. This has been happening since awhile back as well. The entire software has been purged from my pc ala revo uninstallers forced uninstall option, and its installed to my system drive so I have no idea. Ill provide whatever you guys need, and to be fair - automatically updating/updating properly is far down the list for me from Profile switching and finding games when it scans so /shrug.

    Let me know if i can be of any other help

    upload_2018-9-21_8-37-44.png
     
    Last edited by a moderator: Oct 17, 2018
  15. Talezeusz

    Talezeusz New Member

    Good update, looks like synapse stopped randomly forfetting active profiles after launch. Now i just hope you gonna bring Mug Holder to Synapse 3, i don't get how item that was released last year and heavily promoted with zsilver release is only available in synapse 2. I have 6 chroma devices and it's the only one that can't be synced with the rest so it's useless right now
     
  16. OverGamerPL

    OverGamerPL Member

    Now, wait for all the errors, the "Chroma Connected device program" and the new effects I mentioned
     
  17. okonietoperza

    okonietoperza Active Member

    I hope that's now actually fixed, not like with the last update
    THANK YOU. Finally. One bug report to cross out.
    I'm quite sure this was affecting me as well, good - will test.
    Also good. I've sent at least one bug report about this one.

    Thanks for the detailed changelog, really appreciate it. And for the work, to the devs
     
  18. brlowe

    brlowe New Member

    How can I share my logs as my Huntsman Elite and mouse pad running on Synapse 3 are always giving me problems. The lighting cannot be changed and most of the time is not working right.
     
  19. BlackFireDragon

    BlackFireDragon Well-Known Member

    You open synapse 3 and click on right upper corner on your profile next you select feedback. You must fill this card and check send logs on bottom of card.
     
  20. NahuelCC

    NahuelCC Member

    I have exactly the same problem. I just noticed today that there was an update because I visited the forums.

    I had to update manually via the installer. Now after the 3.3.918.91818 update, Synapse3 will not boot at startup. I had to manually open it.

    Could you please fix these basic issues? With every bug-fixing update you make, you introduce new bugs.
     
    Last edited: Oct 3, 2018
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >