[Synapse 3 update] // 31-Jan-2019 // Release announcement

Discussion in 'Razer Synapse 3 Beta' started by RazerThe_Fiend, Jan 31, 2019.

  1. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    Start-up issues are priority #1 for us to fix. If you can capture your logs using this tool and PM them to me, i'll try and personally follow up on it.
     
    PureWicked likes this.
  2. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    I can't say for sure. Pretty much all pending peripherals are "problem" devices, which have at least one critical issue with Synapse 3, and we definitely won't be migrating any device with known issues.

    It doesn't entirely have to do with priorities. But if we have to choose between spending 4 weeks on going a wild goose-chase for a bug-fix of a single device (and there's no guarantee we'd find a fix) vs delivering things that people have been asking for, it makes the choice very difficult.
     
    Last edited: Feb 3, 2019
    RocketSkates93 likes this.
  3. frogdude

    frogdude New Member

    Hello and thank you for your reply. The tool you gave me generated a 39mb .zip file. I sent the file over PM via a wetransfer link. Please confirm that you received the files and that everything is ok.
     
  4. buboblack

    buboblack New Member

    I tried restart, as well as a fresh installation of synapse on Windows 7 64-bit and my Naga Trinity still isn't detected.
     
  5. snorskan

    snorskan New Member

    CAN profiles be added to choma on synapse 3 now?
     
  6. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    I have received the files and shared them with the engineering team.

    If you are referring to the import/export functionality, it was restored back in October.
     
  7. snorskan

    snorskan New Member

    yes that's what am i referring to, but how come when i download a profile from the razer website synapse3 doesn't recognize it
     
  8. RocketSkates93

    RocketSkates93 Well-Known Member

    @RazerThe_Fiend

    By the way, I noticed that the Razer Turret for the Xbox One is listed to be compatible with Synapse 3 and I just want to ask if there are any plans of also adding the Razer Wolverine Ultimate or other Chroma enabled console devices to the PC Synapse ecosystem. They're technically not "legacy" devices since they were made after Synapse 3 was launched but they weren't developed with the thought of being PC peripherals.

    There are some games out there for the PC that would be more fun to play on a controller and I figure that it would be interesting to be able to sync Chroma enabled console controllers with other Chroma enabled PC peripherals. I would love to be able to buy a Razer Raiju (I like the PlayStation layout better) for the PC if it can sync with Synapse 3 Chroma.
     
  9. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    I'm not 100% knowledgeable on this matter, but as far as I understand, this isn't possible at all because the controller's protocol (HID-equivalent for Keyboard/mouse) is not available for Win32, so even PC users need to use the UWP app for configuration.
     
    RocketSkates93 likes this.
  10. Zer0_Kelvin

    Zer0_Kelvin New Member

  11. RazerThe_Fiend

    RazerThe_Fiend Well-Known Member Staff Member

    This is a change in implementation (not a bug) and there is no intention to revert this behavior back to the Synapse 2 way. We used to get AN ABSOLUTE TON of complaints from users during Synapse 2 days that the macro would still play the entire thing and not stop where asked.
     
    Last edited: Feb 11, 2019
  12. BlackFireDragon

    BlackFireDragon Well-Known Member

    @RazerThe_Fiend with this bugs i write in this topic nothing change via email support i get messages like replacement devices or cheack on difrent pc. The thing is for nari it's spefcific bug that enable only in certein action and show in this version for light blink it's nothing, Can i send you a case id ?
     
  13. Stormhoves

    Stormhoves New Member

    Still having the crackling issue on my Nari ultimate.
    I have 2-3 open tickets from different channels. So far no fix came through even with different mainupaltions asked everytime.
    Best workaround : be lucky to find a computer where it works (or set it up as you whish it while it crackles) then cleanly remove/uninstall everythin synapse related.
    Then unplug your headset.
    Then reinstal Synapse. Turn off autoupdates for synapse.
    Then plug your headset but when prompted to update dont.
    Your headset should work as set up before but not show up in Synapse, hence not crackle

    Still waiting for a synapse fix. Good thing is its purely a software issue, sad thing is its only a software fix.
     
  14. Zer0_Kelvin

    Zer0_Kelvin New Member

    .......

    1. In the 'Synapse 2' days, how does one STOP the macro when ASKING?
    As your English implies that users wanted to stop the macro, but the macro wouldn't stop when asking it to.

    2. In the new Synapse 3 software, when a user presses a button with a macro assigned, the macro plays through to the end, does it not?

    2b. In Synapse 3 software, Is there a way to stop the macro from completing? If so, how?
     
  15. Zer0_Kelvin

    Zer0_Kelvin New Member

    @RazerThe_Fiend

    So are you saying then, that once a macro kicks off, I just need to sit there and do do nothing and wait for it to do its thing without being able to use the gamepad (Tartarus) until it's finished?

    IF NOT then I risk interrupting the macro by pressing some other button on the gamepad?

    So, a prime example is, using the D-PAD for a character's movement (which is definitely not uncommon) would interrupt a macro that's currently in progress?

    https://insider.razer.com/index.php...-macro-when-switch-keymap-key-released.46739/
    If you read and understood this post, you'll know that I simply want to continue to do other things while a macro is being kicked off (Like Moving my Character with the D-PAD, and letting up on the Switch Keymap button).
     
  16. frogdude

    frogdude New Member

    Ok, so it still doesn't work. The problem goes like this - i install Synapse 3 latest version, it works fine for a day or two, then, for some unknown reason, it starts failing to load at startup (i get the Razer Synapse splash screen with the "Starting" bar that keeps going and never stops).

    The uninstaller also doesn't work, it gets stuck. I have to manually delete the Synapse 3 folders and uninstall the drivers, then, when i reinstall Synapse 3, it works fine for a day or two, afterwards it starts failing to load and i have to do the procedure above all over again.

    Again, everything worked fine before the January 31st update.

    @RazerThe_Fiend - any news from the tech team regarding my problem?
     
    Last edited: Feb 16, 2019
  17. off3nc3

    off3nc3 New Member

    Blackwidow Chroma Tournament V2 and Naga Trinity are not seen on synapse 3.0 im using win 7 and I can only get the keyboard to work on synapse 2.0 . The Naga Trinity is unusable on both programs.

    This is my fault for purchasing new razer tech when their beta software is still glitchy and buggy almost one year later.
     
  18. honimage

    honimage New Member

    I really don't understand your priorities. instead of focusing on bells and whistles you should focus on migrating all the hardware you are still selling to synapse 3.
    In my case , I have the orbweaver and razer naga,which broke down so I bought the naga trinity. What do you propose i do ? install both versions of synapse ?
     
  19. off3nc3

    off3nc3 New Member

    No matter what you do the Naga Trinity won't work on either 2.0 or 3.0 since the last update . I spent 4 hours with it last night on 2 different PCs . Still waiting for that update that broke win 7 support .
     
  20. Kpacycki

    Kpacycki New Member

    This same but on Mamba Elite. I try on diffrent PC with win 7 and synapse dont see mouse ;/
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >