Synapse 3's Equalizer stops functioning

Discussion in 'Razer Synapse' started by Nicholas9, Apr 24, 2020.

Tags:
Thread Status:
Not open for further replies.
  1. Nicholas9

    Nicholas9 New Member

    Hi, ever since I've had my Razer Nari and Razer Nari Ultimate, I've noticed that my Equalizer stops working. There's a noticeable difference in sound quality too, before and after I 'repaired' Synapse 3. I've been in contact with Razer for a while and we tried basically everything. TLDR; They told me it's a hardware/software issue on my end. And basically stopped assisting me any further. So hence why I'm asking for help here at what might/could be causing this issue to happen cause I can't figure it out myself.

    After I repair my Synapse, the equalizer works again and the sound quality is perfect. But this usually doesn't last long and almost always it goes back to being broken after I restart my laptop. Everything else works fine, the enhancements, mic and lighting. Any help is appreciated.
     
    16002604, Timothy321 and pancholr like this.
  2. ajm4992

    ajm4992 New Member

    Same thing has happened to me! No help so far either. I have a Razer Kraken Ultimate though but same exact issues. It seems to be something with passing information to the THX drivers. Help is really required on an expensive product like this that just flat out doesnt work with all the features
     
    16002604, Timothy321 and pancholr like this.
  3. Tachiibana

    Tachiibana New Member

    I'm having the same issue. I'll be messing with my EQ settings using Itunes as a reference and it will just stop accepting new setting altogether. They will set, but no audio changes will occur. Only fix seems to be restarting my PC. Incredibly salty I spent 180 dollars for software that doesn't function properly.
     
    16002604, Timothy321 and pancholr like this.
  4. lanmine

    lanmine New Member

    same, synapse eq not working.... last razer product ever
     
    16002604, Timothy321 and pancholr like this.
  5. ermaneng

    ermaneng New Member

    same here eq in synapse 3 doesnt seem to be functioning
     
    16002604, Timothy321 and pancholr like this.
  6. CptTwinkie

    CptTwinkie New Member

    I'm having the same problem for months with my nari ultimate headset. I read somewhere that uninstalling and cleaning the registry helped until synapse updated again. It doesn't work anymore, probably because the installer has been updated. This makes me think this is a software problem. Surely someone at razer can install this headset and hear that it doesn't work. I've confirmed that they don't work on three computers, the third one was a new laptop from my office with a fresh installation of Windows 10. I know the hardware is good because the headset was working fine when I got it.

    Edit: I played around with this some more trying to narrow it down. I noticed that when THX is selected as the default output, the sound will come through the game channel no matter what the mixer settings are in synapse. This isn't terribly surprising since most of the other synapse settings aren't working but I thought it might add something for support to look at.

    upload_2020-9-2_17-53-11.png
     
    Last edited: Sep 3, 2020
    0x3f8 likes this.
  7. tak0o0

    tak0o0 New Member

    Updating the synapse fixed it for me. Hope it helps.
     
  8. CptTwinkie

    CptTwinkie New Member

    No change for me after the update. I'll try a clean install

    Update: reinstall (with registry cleaning) didn't help
     
    Last edited: Sep 28, 2020
  9. Garpen1337

    Garpen1337 New Member

    same problem for me. i cant report the bug through synapse and their website is a fucking mess. im so pissed of right now and eventhough i love my blackwidow and nari ultimate i feel like i never want to buy razer products again since they never care to fix their software
     
  10. CptTwinkie

    CptTwinkie New Member

    another update for synapse. no thx at all right now. thanks, razer.
     
  11. 292ff83b

    292ff83b New Member

    Same here, EQ and Mixer don't work... awesome
     
  12. mitcHELLspawn

    mitcHELLspawn New Member

    well, I don't really know why I am responding because it doesn't seem that Razer actually cares whatsoever.. but I guess I would throw my hat in the pile.... I have Nari Ultimate headset and constantly have issues with Synapse Equalizer. Sometimes it works, and sometimes it doesn't. A lot of times I can get the equalizer to start working again by rebooting, but sometimes it doesn't do anything. I am also running Razer Leviathan sound bar/sub and so I'm always switching back and forth between the 2 in my Windows sound settings.
     
  13. RJGamer1002

    RJGamer1002 New Member

    this is what I did to fix my headset was go to sound control panel. click properties for thx spatial and go to advance and enable signal enhancements and that what fix my nari ultimate

    edit: nvm that did not fix it
     

    Attached Files:

    Last edited: Nov 25, 2020
  14. puggyy1

    puggyy1 New Member

    Why they dont fix this ffs.
     
  15. Meisner57

    Meisner57 New Member

    Anyone able to get this fixed? The above about enabling enhancements is already ticked for me.
     
  16. iguana46

    iguana46 New Member

    Same problem here it does not detect my profiles. Because it does not detect my game when starting it. I have to be restarting the pc for it to work
     
    AdrianPHA0323 likes this.
  17. Same issue for me but what seems to have let`s say "tuned it down" to almost nothing is switching the audio output from THX to Game. Sound is the same and you don`t need to mess up with the "enable audio enhancements" options in the sounds settings.
     
  18. RJGamer1002

    RJGamer1002 New Member

    it look like the synapse software stop detecting that it set to default. also, the button dose not work and even though it is set to default.
     

    Attached Files:

  19. headDeepLemon841

    headDeepLemon841 New Member

    I am having this exact issue. Same issue as Rjgamer --- i have 'set as default' button -- but it is default. EQ does nothing, but it did last week when i first got the kraken headset....

    EDIT: Performing a repair install seems to have resolved it, for now!
     
    Last edited: Nov 18, 2020
  20. RJGamer1002

    RJGamer1002 New Member

    that what I did but it will go back after a while.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >