Synapse and Mamba on macOS 10.14 Mojave Beta - Shortcuts not Working

Discussion in 'Razer Synapse' started by michaelsheaver, Jun 18, 2018.

Thread Status:
Not open for further replies.
  1. That wouldn't work, at least in my case. With the headset HAL driver in place, you don't stay logged in long enough to make those modifications. That's with 1.83. The new 1.84, supposedly good with Mojave - doesn't even install!
     
  2. thatcomputerguy

    thatcomputerguy New Member

    At the risk of suggesting that which you have already tried. I had to completely uninstall 1.83 and clean up the stuff from application support and lauchdeamons then reboot then reinstall 1.84 to get it to go. Otherwise, it acted like it was upgrading but failed. I chalked it up to being on the developer seed at the time. 1.84 sorted worked but got worse over 2 weeks until I made the fileaccess change.
     
  3. Interesting. I did clean up what was installed via 1.83 (by moving files into various *.disabled folders). Pretty sure I rebooted at least once, if not several times before trying 1.84. I too went through the beta version of Mojave but I'm on stable/public now.

    Since the 1.83 files are of no use to me, I'm going to go ahead and actually delete all traces of it, reboot and try again with the 1.84 install. Note that previous attempts didn't fail - they just didn't actually DO anything, either (e.g. install files where they need to go).
     
  4. thatcomputerguy

    thatcomputerguy New Member

    That mirrors what I went through; prior to the rip and tear do over. Will be interested in your results.
     
  5. Well I'll be a monkey's uncle...

    I literally had to delete *everything* - Frameworks, Extensions, Audio HAL plug-in, Application Support files (both in /Library and ~/Library) and finally the actual application itself... THEN the 1.84 installer finally worked. It prompted me to allow access in System Preferences. After that, it was all working!

    The application itself is a bit glitchy though, in the UI.
     
  6. thatcomputerguy

    thatcomputerguy New Member

    Excellent; maybe there is hope for all of us. I'm glad you took blind faith and tried again now we have n=2 working.
     
  7. I'm glad too... Now I can stop clicking the side mouse button - and have nothing happen. :D
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >